aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-03-31 07:28:45 -0500
committerMatt Smith <mcs@darkregion.net>2011-03-31 07:28:45 -0500
commit01b2f5b66b1fdac7e42a2c2205661ff712365f18 (patch)
tree18a66d9548505d72b2077be10d507d4614b81ea5 /testing
parentbf17c7ead2d220d467c13420815aa19105e805ac (diff)
downloadaports-01b2f5b66b1fdac7e42a2c2205661ff712365f18.tar.bz2
aports-01b2f5b66b1fdac7e42a2c2205661ff712365f18.tar.xz
main/znc: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/znc/APKBUILD109
-rw-r--r--testing/znc/libiconv.patch16
2 files changed, 0 insertions, 125 deletions
diff --git a/testing/znc/APKBUILD b/testing/znc/APKBUILD
deleted file mode 100644
index c9047564d0..0000000000
--- a/testing/znc/APKBUILD
+++ /dev/null
@@ -1,109 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=znc
-pkgver=0.098
-pkgrel=0
-pkgdesc="An advanced IRC bouncer"
-url="http://znc.in"
-arch="all"
-license="GPLv2"
-depends=
-depends_dev=
-makedepends="perl-dev openssl-dev cyrus-sasl-dev python-dev c-ares-dev swig
- libiconv-dev tcl-dev autoconf automake"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-extra $pkgname-modtcl
- $pkgname-modperl"
-source="http://znc.in/releases/znc-$pkgver.tar.gz
- libiconv.patch"
-
-_builddir="$srcdir"/znc-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- aclocal && autoconf || return 1
-}
-
-build() {
- cd "$_builddir"
- export CHARSET=
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-extra \
- --enable-perl \
- --enable-sasl \
- --enable-tcl \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-_mv_to_sub() {
- local i
- for i in "$@"; do
- mkdir -p "$subpkgdir"/${i%/*}
- mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
- done
-}
-
-_mv_mod() {
- local i
- for i in "$@"; do
- _mv_to_sub usr/lib/znc/$i || return 1
- done
-}
-
-dev() {
- default_dev
- _mv_to_sub usr/bin/znc-buildmod
-}
-
-extra() {
- pkgdesc="Extra modules for ZNC"
- _mv_mod antiidle.so \
- autovoice.so \
- block_motd.so \
- charset.so \
- clearbufferonmsg.so \
- ctcpflood.so \
- droproot.so \
- email.so \
- fakeonline.so \
- flooddetach.so \
- imapauth.so \
- listsockets.so \
- log.so \
- motdfile.so \
- notify_connect.so \
- saslauth.so \
- send_raw.so \
- shell.so
-}
-
-modtcl() {
- pkgdesc="TCL module for ZNC"
- depends="znc"
- _mv_mod modtcl.so
- _mv_to_sub usr/share/znc/modtcl
-}
-
-modperl() {
- pkgdesc="Perl module for ZNC"
- depends="znc"
- _mv_mod modperl modperl.so
-}
-
-md5sums="5667b4acb1f01309d6eded77abac700c znc-0.098.tar.gz
-90b3493803bf7a3aa224e6cbbd644bdf libiconv.patch"
diff --git a/testing/znc/libiconv.patch b/testing/znc/libiconv.patch
deleted file mode 100644
index 0af3a21048..0000000000
--- a/testing/znc/libiconv.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./configure.ac.orig
-+++ ./configure.ac
-@@ -419,7 +419,12 @@
- if test x"$EXTRA" = "xyes"
- then
- AC_CHECK_FUNC( iconv, CHARSET=1 )
-- AC_CHECK_LIB( iconv, iconv_open, LIBICONV=-liconv ; CHARSET=1 )
-+ dnl On some systems iconv is in a separate library, and may actually
-+ dnl be named libiconv.
-+ AC_CHECK_LIB( iconv, libiconv_open, LIBICONV=-liconv ; CHARSET=1 )
-+ if test $ac_cv_lib_iconv_libiconv = no; then
-+ AC_CHECK_LIB( iconv, iconv_open, LIBICONV=-liconv ; CHARSET=1 )
-+ fi
- if test "x$CHARSET" = "x1"
- then
- AC_MSG_CHECKING([whether iconv expects a const second argument])