aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2017-03-16 23:13:13 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-17 20:57:19 +0100
commit071975227845e3f060168aa394201fadb2d7dc42 (patch)
tree334e9aae6d3ba0b3a0a6fb91fc6ee640f50a704f /testing
parent812b2be7d4afb94ff4eb27785f655fa8a1f5f956 (diff)
downloadaports-071975227845e3f060168aa394201fadb2d7dc42.tar.bz2
aports-071975227845e3f060168aa394201fadb2d7dc42.tar.xz
testing/php7.1: upgrade to 7.1.3
Bug fix release http://php.net/archive/2017.php#id2017-03-16-2
Diffstat (limited to 'testing')
-rw-r--r--testing/php7.1/APKBUILD12
-rw-r--r--testing/php7.1/getrandom.patch128
-rw-r--r--testing/php7.1/php7.1-module.conf2
3 files changed, 6 insertions, 136 deletions
diff --git a/testing/php7.1/APKBUILD b/testing/php7.1/APKBUILD
index 8dcb59d25c..e39d6236de 100644
--- a/testing/php7.1/APKBUILD
+++ b/testing/php7.1/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=php7.1
-pkgver=7.1.2
-pkgrel=7
+pkgver=7.1.3
+pkgrel=0
_apiver=20160303
_suffix=${pkgname#php}
_pkgreal=${pkgname%$_suffix}
@@ -28,7 +28,6 @@ source="http://php.net/distributions/$_pkgreal-$pkgver.tar.bz2
$pkgname-fpm.patch
$pkgname-includedir.patch
install-pear.patch
- getrandom.patch
"
# unimplemented extensions: com_dotnet interbase oci8 pdo_firebird pdo_oci
_extension_dir=/usr/lib/$pkgname
@@ -436,11 +435,10 @@ _extension() {
"$subpkgdir"/$_extension_conf/$(printf %02d $index)_$name.ini
}
-sha512sums="b4a3492f4af92facd16e7dfb47ec16b43e4c5b25be193ff6e36418173893edb75ca4ca94767b643a6971d60578727fa1f67f20cc84b9a140cb1b9a367ec34a6f php-7.1.2.tar.bz2
-2801d6e0656b0a9eb090c6a3eee711588515a600e1292a6ba5ce24302c57bb7feb128139c0eb7715af0ddc2f40a7a2832c6e4153fe4d3a467297957a4afb3123 php7.1-module.conf
+sha512sums="90dd06348d5884a2bb4a22ab80bb4f50e603751a1787096f447762fe00e5b4f36deafda045ecf6345883d9f4b711755a854a2e7043f27702acfe78ade90b42d9 php-7.1.3.tar.bz2
+663f08f462eb9a0dbf10df336c5efce2aac5b02b5d8d43d11d44e6024fa8bb933f0371cc5d943e7a42c04a5294936c3958ceabb3e48092a4edb6f5a512d2a878 php7.1-module.conf
066db134f9cd4695caf62cbb970bd13cbcf8d074a8e378945e2c6e80d3b8f4125f7cee2ee5b379359881958955d9737eb24cbfdb72d11c19bd432101ee119501 php7.1-fpm.logrotate
bf8bfbd33134acaa5395336005361519ded1062f461483c18cf69d0395c4fb950802fcfb186c9b54ac382c51e2b634341757ffff9eb7af2dcf017be5af587d1f php7.1-fpm.initd
5e5073aca1ac3c4b1163d7c943f059d00faf04f29db766a0fc1ed3aecf9b7260491c5703aff651baa7ca944d750ff0318ce66aaac5b8500f41056b5357d3fa9f php7.1-fpm.patch
3f5da2f3b904ceb14f8507b924b046dfbee601e274fd501150a78fe362983ee1209ce596e880ed5481a857c4eb9d3deba26c4c14d04fd58075be93e98436f0cd php7.1-includedir.patch
-f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch
-da012a82c00f9dfd3b6e446e2c3e7da597079e9b428f53ca61b5e216c304e3c02e953a5fc2759e516580cb98f08e86b0f5b33ea8df99a8003ae33fcb431463b4 getrandom.patch"
+f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 install-pear.patch"
diff --git a/testing/php7.1/getrandom.patch b/testing/php7.1/getrandom.patch
deleted file mode 100644
index 205a226b4e..0000000000
--- a/testing/php7.1/getrandom.patch
+++ /dev/null
@@ -1,128 +0,0 @@
---- a/ext/standard/random.c
-+++ b/ext/standard/random.c
-@@ -93,14 +93,13 @@ PHPAPI int php_random_bytes(void *bytes, size_t size, zend_bool should_throw)
- }
- #elif HAVE_DECL_ARC4RANDOM_BUF && ((defined(__OpenBSD__) && OpenBSD >= 201405) || (defined(__NetBSD__) && __NetBSD_Version__ >= 700000001))
- arc4random_buf(bytes, size);
--#elif defined(__linux__) && defined(SYS_getrandom)
-- /* Linux getrandom(2) syscall */
-+#else
- size_t read_bytes = 0;
-- size_t amount_to_read = 0;
- ssize_t n;
--
-+#if defined(__linux__) && defined(SYS_getrandom)
-+ /* Linux getrandom(2) syscall */
- /* Keep reading until we get enough entropy */
-- do {
-+ while (read_bytes < size) {
- /* Below, (bytes + read_bytes) is pointer arithmetic.
-
- bytes read_bytes size
-@@ -110,11 +109,17 @@ PHPAPI int php_random_bytes(void *bytes, size_t size, zend_bool should_throw)
- amount_to_read
-
- */
-- amount_to_read = size - read_bytes;
-+ size_t amount_to_read = size - read_bytes;
- n = syscall(SYS_getrandom, bytes + read_bytes, amount_to_read, 0);
-
- if (n == -1) {
-- if (errno == EINTR || errno == EAGAIN) {
-+ if (errno == ENOSYS) {
-+ /* This can happen if PHP was compiled against a newer kernel where getrandom()
-+ * is available, but then runs on an older kernel without getrandom(). If this
-+ * happens we simply fall back to reading from /dev/urandom. */
-+ ZEND_ASSERT(read_bytes == 0);
-+ break;
-+ } else if (errno == EINTR || errno == EAGAIN) {
- /* Try again */
- continue;
- }
-@@ -130,53 +135,52 @@ PHPAPI int php_random_bytes(void *bytes, size_t size, zend_bool should_throw)
- }
-
- read_bytes += (size_t) n;
-- } while (read_bytes < size);
--#else
-- int fd = RANDOM_G(fd);
-- struct stat st;
-- size_t read_bytes = 0;
-- ssize_t n;
-+ }
-+#endif
-+ if (read_bytes < size) {
-+ int fd = RANDOM_G(fd);
-+ struct stat st;
-
-- if (fd < 0) {
-+ if (fd < 0) {
- #if HAVE_DEV_URANDOM
-- fd = open("/dev/urandom", O_RDONLY);
-+ fd = open("/dev/urandom", O_RDONLY);
- #endif
-- if (fd < 0) {
-- if (should_throw) {
-- zend_throw_exception(zend_ce_exception, "Cannot open source device", 0);
-+ if (fd < 0) {
-+ if (should_throw) {
-+ zend_throw_exception(zend_ce_exception, "Cannot open source device", 0);
-+ }
-+ return FAILURE;
- }
-- return FAILURE;
-- }
-- /* Does the file exist and is it a character device? */
-- if (fstat(fd, &st) != 0 ||
-+ /* Does the file exist and is it a character device? */
-+ if (fstat(fd, &st) != 0 ||
- # ifdef S_ISNAM
-- !(S_ISNAM(st.st_mode) || S_ISCHR(st.st_mode))
-+ !(S_ISNAM(st.st_mode) || S_ISCHR(st.st_mode))
- # else
-- !S_ISCHR(st.st_mode)
-+ !S_ISCHR(st.st_mode)
- # endif
-- ) {
-- close(fd);
-- if (should_throw) {
-- zend_throw_exception(zend_ce_exception, "Error reading from source device", 0);
-+ ) {
-+ close(fd);
-+ if (should_throw) {
-+ zend_throw_exception(zend_ce_exception, "Error reading from source device", 0);
-+ }
-+ return FAILURE;
- }
-- return FAILURE;
-+ RANDOM_G(fd) = fd;
- }
-- RANDOM_G(fd) = fd;
-- }
-
-- while (read_bytes < size) {
-- n = read(fd, bytes + read_bytes, size - read_bytes);
-- if (n <= 0) {
-- break;
-+ for (read_bytes = 0; read_bytes < size; read_bytes += (size_t) n) {
-+ n = read(fd, bytes + read_bytes, size - read_bytes);
-+ if (n <= 0) {
-+ break;
-+ }
- }
-- read_bytes += n;
-- }
-
-- if (read_bytes < size) {
-- if (should_throw) {
-- zend_throw_exception(zend_ce_exception, "Could not gather sufficient random data", 0);
-+ if (read_bytes < size) {
-+ if (should_throw) {
-+ zend_throw_exception(zend_ce_exception, "Could not gather sufficient random data", 0);
-+ }
-+ return FAILURE;
- }
-- return FAILURE;
- }
- #endif
-
diff --git a/testing/php7.1/php7.1-module.conf b/testing/php7.1/php7.1-module.conf
index 80f2654f63..230840a64f 100644
--- a/testing/php7.1/php7.1-module.conf
+++ b/testing/php7.1/php7.1-module.conf
@@ -1,4 +1,4 @@
-LoadModule php7.1_module modules/mod_php7.1.so
+LoadModule php7_module modules/mod_php7.1.so
DirectoryIndex index.php index.html
AddHandler application/x-httpd-php .php