aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFusl <root@hallowe.lt>2018-01-26 15:24:28 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-01-27 13:49:38 +0000
commit086595299761c604747f7ed0fc7ecabe6fc365b1 (patch)
tree4d8e1741a07496050a7d0d0fe08c7d81119e49f3 /testing
parentf5e725820c8ff11c3c6d0700cded67947e5559b3 (diff)
downloadaports-086595299761c604747f7ed0fc7ecabe6fc365b1.tar.bz2
aports-086595299761c604747f7ed0fc7ecabe6fc365b1.tar.xz
testing/obfs4proxy: initial package commit based on version 0.0.7
Diffstat (limited to 'testing')
-rw-r--r--testing/obfs4proxy/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/obfs4proxy/APKBUILD b/testing/obfs4proxy/APKBUILD
new file mode 100644
index 0000000000..9e74ad5bb2
--- /dev/null
+++ b/testing/obfs4proxy/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Katie Holly <holly@fuslvz.ws>
+# Maintainer: Katie Holly <holly@fuslvz.ws>
+pkgname=obfs4proxy
+pkgver=0.0.7
+pkgrel=0
+pkgdesc="pluggable transport proxy for Tor, implementing obfs4"
+url="https://gitweb.torproject.org/pluggable-transports/obfs4.git/"
+arch="x86_64 x86"
+license="BSD-3-Clause"
+makedepends="go"
+options="!strip"
+install=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yawning/obfs4/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/obfs4-$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ go get -d ./$pkgname
+ go build -v -o ./$pkgname-executable ./$pkgname
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+ install -Dm755 $pkgname-executable "$pkgdir"/usr/bin/$pkgname
+}
+
+sha512sums="57b71138a139b1821cf58c8e1965f207a6164a046bbfc8d6da828351d4f5bf4ecfb63ca5c69dba834c4e3a72362089d2a7fd296278115c0cae1c53c51d1b124d obfs4proxy-0.0.7.tar.gz"