aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-07-10 20:42:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-10 20:44:30 +0000
commit10787b01694fade1c6faaf5f1722c333dae78f51 (patch)
tree0e0f7e3ba29efafb63ab3070fba8ce10c9147298 /testing
parent6e33426e8e62d434382adbd857d04bf2002bcf48 (diff)
downloadaports-10787b01694fade1c6faaf5f1722c333dae78f51.tar.bz2
aports-10787b01694fade1c6faaf5f1722c333dae78f51.tar.xz
Revert "testing/spotifyd: new aport"
This reverts commit 8b513e216ef1034a2a4d6b988adc873c930215ab. we need figure out how to deal with cargo properly
Diffstat (limited to 'testing')
-rw-r--r--testing/spotifyd/APKBUILD41
-rw-r--r--testing/spotifyd/spotifyd.confd1
-rw-r--r--testing/spotifyd/spotifyd.initd12
-rw-r--r--testing/spotifyd/spotifyd.pre-install5
4 files changed, 0 insertions, 59 deletions
diff --git a/testing/spotifyd/APKBUILD b/testing/spotifyd/APKBUILD
deleted file mode 100644
index dcc359b146..0000000000
--- a/testing/spotifyd/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Dawid Dziurla <dawidd0811@gmail.com>
-pkgname=spotifyd
-_sha=e7861116b16158d3ef7d875401c082b9bc634837
-pkgver=20170702
-pkgrel=0
-pkgdesc="A spotify playing daemon"
-url="https://github.com/Spotifyd/spotifyd"
-arch="x86_64 armhf"
-license="GPL-3.0"
-depends=""
-install="$pkgname.pre-install"
-makedepends="cargo portaudio-dev protobuf-dev alsa-lib-dev"
-subpackages=""
-options="!check"
-source="$pkgname-$pkgver.zip::$url/archive/$_sha.zip
- $pkgname.initd
- $pkgname.confd
- "
-builddir="$srcdir/$pkgname-$_sha"
-
-build() {
- cd "$builddir"
- export CARGO_HOME="$srcdir"/cargo
- export RUSTFLAGS="-C target-feature=-crt-static"
- cargo build \
- --release \
- --verbose \
- --features alsa_backend
-}
-
-package() {
- cd "$builddir"
- install -Dm755 target/release/$pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-sha512sums="74875b6a38a76de4d64c3ca8d551fbe8841426862356097329aac02543ce03a63e83a4dd8046541be189d3b7a01fc8c3cbd226d27f7cf364dd18665b234a5282 spotifyd-20170702.zip
-f8b121c91e96367ca52ab40c328cd4bdfbfeacc443a5ab745a79232e08d4ef6458f2233a832727d59b7a732fc41d9e41765bb7fa692619b20666eae72ea1afe2 spotifyd.initd
-f892204b0d6585c0d381bd41060bfd270ba649ef97acf2baf3936077b0a907f249aed5aac7b41b2e5a2efb905c2cd13ce05868e440a1ac37d46b2b384de789a6 spotifyd.confd"
diff --git a/testing/spotifyd/spotifyd.confd b/testing/spotifyd/spotifyd.confd
deleted file mode 100644
index 55c9eb468c..0000000000
--- a/testing/spotifyd/spotifyd.confd
+++ /dev/null
@@ -1 +0,0 @@
-spotifyd_args="--no-daemon"
diff --git a/testing/spotifyd/spotifyd.initd b/testing/spotifyd/spotifyd.initd
deleted file mode 100644
index a25986d2d2..0000000000
--- a/testing/spotifyd/spotifyd.initd
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/sbin/openrc-run
-
-command=/usr/bin/spotifyd
-command_args="${spotifyd_args}"
-pidfile="/run/spotifyd.pid"
-command_background=true
-start_stop_daemon_args="--user spotifyd --group audio"
-
-depends() {
- need localmount net
- before firewall
-}
diff --git a/testing/spotifyd/spotifyd.pre-install b/testing/spotifyd/spotifyd.pre-install
deleted file mode 100644
index aa6214d561..0000000000
--- a/testing/spotifyd/spotifyd.pre-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-adduser -S -D -H -s /sbin/nologin -G audio -g audio spotifyd 2>/dev/null
-
-exit 0