aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-19 11:46:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-19 11:46:38 +0000
commit40dd9e5e3fda4124dff6086653473717da29961d (patch)
tree7529df58bae1563012f548377d90cadb417ceb55 /testing
parentfb9a1ae97a91009e6c2efd10009ecffc633a6f08 (diff)
downloadaports-40dd9e5e3fda4124dff6086653473717da29961d.tar.bz2
aports-40dd9e5e3fda4124dff6086653473717da29961d.tar.xz
testing/mozjs60: build fix
apparently builders does not have $SHELL set, so we set and export it.
Diffstat (limited to 'testing')
-rw-r--r--testing/mozjs60/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/mozjs60/APKBUILD b/testing/mozjs60/APKBUILD
index 53935c13ac..df5b28a53b 100644
--- a/testing/mozjs60/APKBUILD
+++ b/testing/mozjs60/APKBUILD
@@ -9,7 +9,7 @@ arch="all !armhf !armv7"
license="LGPL"
depends=""
depends_dev="icu-dev nspr-dev libffi-dev readline-dev"
-makedepends="$depends_dev zlib-dev python2 perl sed autoconf2.13 linux-headers bash"
+makedepends="$depends_dev zlib-dev python2 perl sed autoconf2.13 linux-headers"
subpackages="$pkgname-dev"
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-${pkgver}esr.source.tar.xz
0001-silence-sandbox-violations.patch
@@ -26,7 +26,8 @@ build() {
# avoid complains about autoconf
touch configure
- SHELL=/bin/bash PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
+ export SHELL=/bin/ash
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
--with-system-icu \
--with-system-nspr \
--with-system-zlib \