aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-09 05:17:19 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-09 05:17:33 +0000
commit5608853c874f3e10418386451b5d97a63173b280 (patch)
tree24f05728f57eaca11ce324b873b13419e970fcce /testing
parent57efaf77dc5764a5e2b3622e19a472492d3980d4 (diff)
downloadaports-5608853c874f3e10418386451b5d97a63173b280.tar.bz2
aports-5608853c874f3e10418386451b5d97a63173b280.tar.xz
testing/rhythmbox: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/rhythmbox/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/rhythmbox/APKBUILD b/testing/rhythmbox/APKBUILD
new file mode 100644
index 0000000000..4c4c877345
--- /dev/null
+++ b/testing/rhythmbox/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=rhythmbox
+pkgver=3.4.1
+pkgrel=0
+pkgdesc="GNOME audio player"
+url="http://wiki.gnome.org/Apps/Rhythmbox"
+arch="all"
+license="GPL"
+depends="py3-gobject3"
+depends_dev="gnome-desktop-dev gstreamer1-dev libpeas-dev"
+makedepends="$depends_dev tdb-dev libsoup-dev json-glib-dev totem-pl-parser-dev gmime-dev libmtp-dev gst-plugins-base1-dev py-gobject3-dev libxslt libxml2-utils docbook-xml docbook-xsl itstool intltool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/rhythmbox/3.4/rhythmbox-$pkgver.tar.xz"
+builddir="$srcdir/rhythmbox-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b00034e9369222f64d5d9c5e246b99f5d738336d3faf2d303c444f84c316688871e0a09992e96012f38e2e90e8efc936ad231bed5057a5aaf31ee66963f59ae6 rhythmbox-3.4.1.tar.xz"