aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-11 12:44:26 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-09-21 22:25:23 +0000
commit5753984347bd83f421953e12d350bf81f78187bb (patch)
treedd10e3c150ea66975650471752c0a4a518268612 /testing
parentcd7a0b09af02c62c98ca10be2e97d62a3a1e9093 (diff)
downloadaports-5753984347bd83f421953e12d350bf81f78187bb.tar.bz2
aports-5753984347bd83f421953e12d350bf81f78187bb.tar.xz
testing/chrpath: new aport
Modify rpath of compiled programs ftp://ftp.hungry.com/pub/hungry/chrpath/
Diffstat (limited to 'testing')
-rw-r--r--testing/chrpath/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/chrpath/APKBUILD b/testing/chrpath/APKBUILD
new file mode 100644
index 0000000000..29cb87b75b
--- /dev/null
+++ b/testing/chrpath/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor:
+# Maintainer:
+pkgname=chrpath
+pkgver=0.13
+pkgrel=0
+pkgdesc="Modify rpath of compiled programs"
+url="ftp://ftp.hungry.com/pub/hungry/chrpath/"
+arch="all"
+license="GPL+"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/chrpath-$pkgver.tar.gz"
+
+_builddir="$srcdir"/chrpath-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" docdir=/usr/share/doc/$pkgname-$pkgver \
+ install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="b73072a8fbba277558c50364b65bb407 chrpath-0.13.tar.gz"