aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-06 14:12:13 +0200
committerBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-06 14:12:23 +0200
commit6e39e9edebf23c79aff703eda309e786eccfa7bf (patch)
tree12097724f7160cffa0e8b75db3a3c0d0c39f465c /testing
parent5868cc5a9534bf1ebb931aaee292d2e6a0e11019 (diff)
downloadaports-6e39e9edebf23c79aff703eda309e786eccfa7bf.tar.bz2
aports-6e39e9edebf23c79aff703eda309e786eccfa7bf.tar.xz
testing/wxgtk: add fix for gcc6
Diffstat (limited to 'testing')
-rw-r--r--testing/wxgtk/APKBUILD12
-rw-r--r--testing/wxgtk/gcc6.patch39
2 files changed, 47 insertions, 4 deletions
diff --git a/testing/wxgtk/APKBUILD b/testing/wxgtk/APKBUILD
index 0be8f42544..7148a5c44b 100644
--- a/testing/wxgtk/APKBUILD
+++ b/testing/wxgtk/APKBUILD
@@ -15,7 +15,8 @@ makedepends="$depends_dev glu-dev sdl-dev gst-plugins-base0.10-dev
install=""
subpackages="$pkgname-dev $pkgname-lang $pkgname-media $pkgname-base"
source="https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2
- config-allow-musl.patch"
+ config-allow-musl.patch
+ gcc6.patch"
builddir="$srcdir/wxWidgets-$pkgver"
@@ -68,8 +69,11 @@ base() {
}
md5sums="ba4cd1f3853d0cd49134c5ae028ad080 wxWidgets-3.0.2.tar.bz2
-4e830ce35be68f904b80c34093153350 config-allow-musl.patch"
+4e830ce35be68f904b80c34093153350 config-allow-musl.patch
+f624f8a0c1163a1376d43f5b57c5f39a gcc6.patch"
sha256sums="346879dc554f3ab8d6da2704f651ecb504a22e9d31c17ef5449b129ed711585d wxWidgets-3.0.2.tar.bz2
-0517cf79f2d2bdc9132e5da2e4717f37b002bf09de77ee5dbe7a46447dee92cb config-allow-musl.patch"
+0517cf79f2d2bdc9132e5da2e4717f37b002bf09de77ee5dbe7a46447dee92cb config-allow-musl.patch
+6e659eb4f1cfbfe31e0da0c8719e496e16efa5be36265388a639964e4b39cf78 gcc6.patch"
sha512sums="098f79863103f3be0b7e21e4f0f1b34ab5277ef0033c1ef1387a9c673b0e0b76a2d732b183fa11b22cfcbbfdb7a4884f243d12f65cd49baa1772852307b393c4 wxWidgets-3.0.2.tar.bz2
-dbe80fbf36afe26bbec66d93842ae849eb29e33d05b762f7eb90f933db7bd415ff174a18c9acb7e71221e9ca9fd70c0c3cebe1fd0f77f348182ddb1a640b4f62 config-allow-musl.patch"
+dbe80fbf36afe26bbec66d93842ae849eb29e33d05b762f7eb90f933db7bd415ff174a18c9acb7e71221e9ca9fd70c0c3cebe1fd0f77f348182ddb1a640b4f62 config-allow-musl.patch
+6da02b4cdd6e4d33cfd8da5554f1400e2ccb33de7fa12d9da23a8eeac52c724fa339d2e1d413abf5f4590cf0514cf9a8d951589d3e498aae936ab10caf93f585 gcc6.patch"
diff --git a/testing/wxgtk/gcc6.patch b/testing/wxgtk/gcc6.patch
new file mode 100644
index 0000000000..119175c624
--- /dev/null
+++ b/testing/wxgtk/gcc6.patch
@@ -0,0 +1,39 @@
+From 73e9e18ea09ffffcaac50237def0d9728a213c02 Mon Sep 17 00:00:00 2001
+From: Scott Talbert <swt@techie.net>
+Date: Sat, 20 Feb 2016 00:08:14 -0500
+Subject: [PATCH] Fix STC compilation with GCC6
+
+Use std::abs() from <cmath> instead of abs() from <math.h> to avoid problems
+with ambiguous overloads.
+
+Closes #17147.
+
+Closes https://github.com/wxWidgets/wxWidgets/pull/222
+---
+ src/stc/scintilla/src/Editor.cxx | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/stc/scintilla/src/Editor.cxx b/src/stc/scintilla/src/Editor.cxx
+index cd72953..2081df2 100644
+--- a/src/stc/scintilla/src/Editor.cxx
++++ b/src/stc/scintilla/src/Editor.cxx
+@@ -11,6 +11,7 @@
+ #include <ctype.h>
+ #include <assert.h>
+
++#include <cmath>
+ #include <string>
+ #include <vector>
+ #include <map>
+@@ -5841,9 +5842,9 @@ void Editor::GoToLine(int lineNo) {
+ }
+
+ static bool Close(Point pt1, Point pt2) {
+- if (abs(pt1.x - pt2.x) > 3)
++ if (std::abs(pt1.x - pt2.x) > 3)
+ return false;
+- if (abs(pt1.y - pt2.y) > 3)
++ if (std::abs(pt1.y - pt2.y) > 3)
+ return false;
+ return true;
+ }