aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-08-05 14:22:49 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-08-05 14:22:56 +0200
commit6ed41186dcd90b01422862f5cfe899278c5971c6 (patch)
tree1d808ca62871ad83b87a1f8000d2cf4a89e7d95a /testing
parentae3ba48afb8835c192f86f09f9540e0dcc344081 (diff)
downloadaports-6ed41186dcd90b01422862f5cfe899278c5971c6.tar.bz2
aports-6ed41186dcd90b01422862f5cfe899278c5971c6.tar.xz
testing/entr: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/entr/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/entr/APKBUILD b/testing/entr/APKBUILD
new file mode 100644
index 0000000000..2c050e7b0b
--- /dev/null
+++ b/testing/entr/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=entr
+pkgver=3.7
+pkgrel=0
+pkgdesc="Run arbitrary commands when files change"
+url="http://entrproject.org/"
+arch="all"
+license="ISC"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://entrproject.org/code/entr-$pkgver.tar.gz"
+builddir="$srcdir/eradman-entr-c5b62bde107d"
+
+build() {
+ cd "$builddir"
+ ./configure
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="a1687ec2da99f65fba3f668e41345ba76cb8c87cc2343d98c0dcc0ac0dedeb40cd8b5fd9aa3eba1dee8add94585de939864633bf0020cea1043699019dfa15fe entr-3.7.tar.gz"