aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Li <andy@onthewings.net>2017-10-16 13:12:54 +0800
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-19 04:58:11 +0000
commit87da97a23a664433b03f7b061abe9685acb21729 (patch)
tree94c98415c9bcdced2def9dc5bc64850ced4c2055 /testing
parentb496b8bf29f6c590d7d3d9e50cb5d528dca34912 (diff)
downloadaports-87da97a23a664433b03f7b061abe9685acb21729.tar.bz2
aports-87da97a23a664433b03f7b061abe9685acb21729.tar.xz
testing/neko: add check(), set maintainer
Diffstat (limited to 'testing')
-rw-r--r--testing/neko/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/neko/APKBUILD b/testing/neko/APKBUILD
index c528740cea..e4c0eeb19b 100644
--- a/testing/neko/APKBUILD
+++ b/testing/neko/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
-# Maintainer:
+# Maintainer: Andy Li <andy@onthewings.net>
pkgname=neko
pkgver=2.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="High-level dynamically typed programming language"
url="http://nekovm.org/"
-arch="x86_64 ppc64le"
+arch="all"
license="LGPL"
depends=""
depends_dev="neko"
@@ -29,6 +29,11 @@ build() {
ninja || return 1
}
+check() {
+ cd "$builddir"
+ ninja -C build test || return 1
+}
+
package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C build install || return 1