aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-01-23 13:05:42 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-23 14:31:38 +0000
commit8f8a6eb185656712e22dff8209d23a93ce7c531e (patch)
tree3175513e6a778aecf2be388979d3426642563c39 /testing
parent8f2c44556b67ccd532654ae17996731523516af6 (diff)
downloadaports-8f8a6eb185656712e22dff8209d23a93ce7c531e.tar.bz2
aports-8f8a6eb185656712e22dff8209d23a93ce7c531e.tar.xz
testing/vice: new aport
Signed-off-by: Leonardo Arena <rnalrd@alpinelinux.org>
Diffstat (limited to 'testing')
-rw-r--r--testing/vice/APKBUILD50
-rw-r--r--testing/vice/disable-fc-cache.patch16
-rw-r--r--testing/vice/musl-fixes.patch13
3 files changed, 79 insertions, 0 deletions
diff --git a/testing/vice/APKBUILD b/testing/vice/APKBUILD
new file mode 100644
index 0000000000..4b5e690a15
--- /dev/null
+++ b/testing/vice/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=vice
+pkgver=3.0
+pkgrel=0
+pkgdesc="emulates the C64/DTV, C128, VIC20, almost all PETs, PLUS4 and CBM-II"
+url="http://vice-emu.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="sdl2-dev giflib-dev ffmpeg-dev jpeg-dev alsa-lib-dev
+ linux-headers texinfo automake autoconf bison flex"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/vice-emu/vice-$pkgver.tar.gz
+ disable-fc-cache.patch
+ musl-fixes.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ sed -i 's/lib64/lib/g' configure.ac || return 1
+ autoreconf -fi || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --enable-sdlui2 \
+ --disable-no-pic \
+ --enable-external-ffmpeg \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" realdocdir="/usr/share/doc/vice" install || return 1
+}
+md5sums="c732d76a70ac1232a43456dae540b43a vice-3.0.tar.gz
+b1dee4fef59f835534683fabbe1fbbce disable-fc-cache.patch
+bdabef5017a68648dbe17ebde5163077 musl-fixes.patch"
+sha256sums="bc56811381920d43ab5f2f85a5e08f21ab5bdf6190dd5dfe9f500a745d14972b vice-3.0.tar.gz
+8058210e092c4943a55baeff47e6d5f3661aeb3686fd1f75e07f47888da9cc98 disable-fc-cache.patch
+0378224bc9a205386a6d9f4d6cee3ab6bcc78d949a6aad8a345084480dcd596a musl-fixes.patch"
+sha512sums="60d33e644d9977df81ffbdceff8c4feec750de9597cfa9f37c4aa236eabbf507373e6f936e2cc3b06f3e7298e0390d1e098242bfacd6435e628a13991a6a452b vice-3.0.tar.gz
+ed6fee34eefcb04c42b4575591dfeffca8548eae354dee66dabdbc4abac0311cbbedcdc07cdfcb01da4840d57ab331a31583e17160820462a2c064835a75d75d disable-fc-cache.patch
+fa9f3ce9322a2bb5475ec703bc9134a6fa23fdffec0b82bb947b848830ecfa8f31f7d5ff195025a57f09be9f99fbbfe368e7293f535068c4d88194f593dc5909 musl-fixes.patch"
diff --git a/testing/vice/disable-fc-cache.patch b/testing/vice/disable-fc-cache.patch
new file mode 100644
index 0000000000..c685b676d4
--- /dev/null
+++ b/testing/vice/disable-fc-cache.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac.orig 2016-12-15 04:44:32.000000000 +0100
++++ b/configure.ac 2017-01-05 23:24:59.072247182 +0100
+@@ -2998,12 +2998,7 @@ if test x"$enable_lame" != "xno" ; then
+
+ fi
+
+-AC_PATH_PROGS(FCCACHE, fc-cache, false)
+-if test x"$FCCACHE" = "xfalse"; then
+- AM_CONDITIONAL(HAVE_FC_CACHE, false)
+-else
+- AM_CONDITIONAL(HAVE_FC_CACHE, true)
+-fi
++AM_CONDITIONAL(HAVE_FC_CACHE, false)
+
+ if test x"$is_amigaos4" = "xyes"; then
+ if test x"$enable_sdlui" != "xyes" -a x"$enable_sdlui2" != "xyes"; then
diff --git a/testing/vice/musl-fixes.patch b/testing/vice/musl-fixes.patch
new file mode 100644
index 0000000000..01ef1a9b9b
--- /dev/null
+++ b/testing/vice/musl-fixes.patch
@@ -0,0 +1,13 @@
+--- a/src/opencbm.h
++++ b/src/opencbm.h
+@@ -129,6 +129,10 @@
+ typedef unsigned char __u_char;
+ #endif
+
++#if (defined(__linux__) && !defined(__GLIBC__))
++typedef unsigned char __u_char;
++#endif
++
+ #endif
+
+ /* specifiers for the IEC bus lines */