aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorDenis Ryabyy <vv1r0x@gmail.com>2016-08-31 09:16:37 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-13 22:25:32 +0200
commitb5d88a11a312925346617b0c403a53f9dab90029 (patch)
tree8a6b4f0ab023c438ff7d477762e2de8834cc7dcb /testing
parentb60972499857b49cfcac97c3f907e70b3ec49adc (diff)
downloadaports-b5d88a11a312925346617b0c403a53f9dab90029.tar.bz2
aports-b5d88a11a312925346617b0c403a53f9dab90029.tar.xz
testing/ctorrent-dnh: new aport
http://www.rahul.net/dholmes/ctorrent/ Enhanced CTorrent is a BitTorrent client for unix-like environments
Diffstat (limited to 'testing')
-rw-r--r--testing/ctorrent-dnh/APKBUILD29
-rw-r--r--testing/ctorrent-dnh/unistd.patch10
2 files changed, 39 insertions, 0 deletions
diff --git a/testing/ctorrent-dnh/APKBUILD b/testing/ctorrent-dnh/APKBUILD
new file mode 100644
index 0000000000..e4af307b10
--- /dev/null
+++ b/testing/ctorrent-dnh/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Denis Ryabyy <vv1r0x@gmail.com>
+# Maintainer: Denis Ryabyy <vv1r0x@gmail.com>
+pkgname=ctorrent-dnh
+pkgver=3.3.2
+pkgrel=0
+pkgdesc="Enhanced CTorrent is a BitTorrent client for unix-like environments"
+url="http://www.rahul.net/dholmes/ctorrent/"
+arch="all"
+license="GPL2"
+source="http://www.rahul.net/dholmes/ctorrent/${pkgname}${pkgver}.tar.gz
+ unistd.patch"
+builddir="$srcdir/${pkgname}${pkgver}"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr && make
+}
+
+package () {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="59b23dd05ff70791cd6449effa7fc3b6 ctorrent-dnh3.3.2.tar.gz
+d017bf6725e4d56d118bfe817bd211e4 unistd.patch"
+sha256sums="c87366c91475931f75b924119580abd06a7b3cb3f00fef47346552cab1e24863 ctorrent-dnh3.3.2.tar.gz
+893d308cdfbca91d610982713de8954d14a1623a6120442d366c0141af218a86 unistd.patch"
+sha512sums="e59b2b899b8603e42a5754d5ce65f661b135b8e107140e0472af379b2b06ee2985239ed0ebf19dcaef788e617b99eac35ad32ad2d10352e2fcf5a6dc084d27dd ctorrent-dnh3.3.2.tar.gz
+0f1e851202c8945c6a8c630b1ea54426bef542c7661c75d0ea97a7bd176cf503ba529a2439b4c13f7c3e7631854c9a207a788ac77fd5774e43b236c76bc57bf0 unistd.patch"
diff --git a/testing/ctorrent-dnh/unistd.patch b/testing/ctorrent-dnh/unistd.patch
new file mode 100644
index 0000000000..f7d8a925e0
--- /dev/null
+++ b/testing/ctorrent-dnh/unistd.patch
@@ -0,0 +1,10 @@
+--- a/compat.h
++++ b/compat.h
+@@ -57,6 +57,7 @@
+ void srandom(unsigned long seed);
+ #endif
+
++#include <unistd.h>
+
+ #ifdef __cplusplus
+ }