aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-10-23 14:11:04 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2012-10-23 14:11:16 +0200
commitb932cc22105d5ff0e1d095f2f92afeeb9706b09f (patch)
treeba6249b9fb0f92ebaaa8304894a2a6491bce221a /testing
parente33b32283ce5d5d2a9411c26c75efd01179c2268 (diff)
downloadaports-b932cc22105d5ff0e1d095f2f92afeeb9706b09f.tar.bz2
aports-b932cc22105d5ff0e1d095f2f92afeeb9706b09f.tar.xz
testing/oscam: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/oscam/APKBUILD61
-rw-r--r--testing/oscam/oscam.conf40
-rw-r--r--testing/oscam/oscam.confd5
-rw-r--r--testing/oscam/oscam.initd30
-rw-r--r--testing/oscam/oscam.pre-install3
5 files changed, 139 insertions, 0 deletions
diff --git a/testing/oscam/APKBUILD b/testing/oscam/APKBUILD
new file mode 100644
index 0000000000..5f69ebfaa3
--- /dev/null
+++ b/testing/oscam/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=oscam
+pkgver=1.10
+pkgrel=0
+pkgdesc="An Open Source Conditional Access Module software"
+url="http://oscam.to"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev bash cmake"
+install="$pkgname.pre-install"
+pkgusers="$pkgname"
+subpackages="$pkgname-doc"
+source="http://alpine.nethq.org/distfiles/oscam-$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ $pkgname.conf"
+
+_builddir="$srcdir"/oscam-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWEBIF=1 \
+ -DWITH_SSL=1 \
+ "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -d -o oscam \
+ "$pkgdir"/var/log/$pkgname || return 1
+ install -d "$pkgdir"/etc/$pkgname/cw || return 1
+ install -D "$srcdir"/$pkgname.conf \
+ "$pkgdir"/etc/$pkgname/$pkgname.conf || return 1
+ chown -R oscam "$pkgdir"/etc/$pkgname
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e6e6d0f760298fd254333b3b56f30ee6 oscam-1.10.tar.gz
+56f8a71e018973b6fb8f2efa2873b6cb oscam.initd
+185840b037fc59248f8ea2f84c2b67ed oscam.confd
+8713bafd03b9b1e8a06c7a843b4dbf88 oscam.conf"
diff --git a/testing/oscam/oscam.conf b/testing/oscam/oscam.conf
new file mode 100644
index 0000000000..70204fa11c
--- /dev/null
+++ b/testing/oscam/oscam.conf
@@ -0,0 +1,40 @@
+[global]
+usrfile = /var/log/oscamuser.log
+logfile = /var/log/oscam.log
+cwlogdir = /etc/oscam/cw
+disablelog = 0
+disableuserfile = 0
+usrfileflag = 0
+clienttimeout = 2000
+fallbacktimeout = 1500
+clientmaxidle = 120
+failbantime = 0
+bindwait = 120
+netprio = 0
+clientdyndns = 0
+resolvedelay = 2
+unlockparental = 0
+nice = -1
+serialreadertimeout = 1000
+maxlogsize = 10
+waitforcards = 1
+preferlocalcards = 1
+saveinithistory = 0
+readerrestartseconds = 5
+lb_mode = 0
+lb_save = 0
+lb_nbest_readers = 1
+lb_nfb_readers = 1
+lb_min_ecmcount = 5
+lb_max_ecmcount = 500
+lb_reopen_seconds = 900
+resolvegethostbyname = 0
+
+[webif]
+httpport = 15080
+httpuser = username
+httppwd = password
+httprefresh = 0
+httpallowed = 127.0.0.1
+httphideidleclients = 0
+httpreadonly = 0
diff --git a/testing/oscam/oscam.confd b/testing/oscam/oscam.confd
new file mode 100644
index 0000000000..3366dcd6b1
--- /dev/null
+++ b/testing/oscam/oscam.confd
@@ -0,0 +1,5 @@
+# oscam confd file
+
+user="oscam"
+group="video"
+args="-b -c /etc/oscam"
diff --git a/testing/oscam/oscam.initd b/testing/oscam/oscam.initd
new file mode 100644
index 0000000000..ed9918fd27
--- /dev/null
+++ b/testing/oscam/oscam.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+
+# oscam init.d
+
+name="oscam"
+daemon="/usr/bin/$name"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting oscam"
+ start-stop-daemon --start \
+ --quiet \
+ --user $user \
+ --group $group \
+ --name $name \
+ --exec $daemon \
+ -- $args
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping oscam"
+ start-stop-daemon --stop \
+ --signal 2 \
+ --name $name
+ eend $?
+}
diff --git a/testing/oscam/oscam.pre-install b/testing/oscam/oscam.pre-install
new file mode 100644
index 0000000000..c78cb9a78e
--- /dev/null
+++ b/testing/oscam/oscam.pre-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+adduser -H -G video -D -s /bin/false oscam 2>/dev/null
+exit 0