aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorV.Krishn <vkrishn4@gmail.com>2016-02-16 15:30:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-16 15:44:18 +0000
commitbd36ab5bb1b6a8fd09a94a41d6cca2f20e049caf (patch)
tree12dd7090d5ff60a4becfb6673bed07ddcd9f17d8 /testing
parent2c52bc892034f81f2c063d7d39e42366bb123793 (diff)
downloadaports-bd36ab5bb1b6a8fd09a94a41d6cca2f20e049caf.tar.bz2
aports-bd36ab5bb1b6a8fd09a94a41d6cca2f20e049caf.tar.xz
testing/php-suhosin: new aport
PHP extension SUHOSIN, An advanced protection system for PHP installations.
Diffstat (limited to 'testing')
-rw-r--r--testing/php-suhosin/0001-php_flock-undefined-variable-fix.patch27
-rw-r--r--testing/php-suhosin/APKBUILD54
2 files changed, 81 insertions, 0 deletions
diff --git a/testing/php-suhosin/0001-php_flock-undefined-variable-fix.patch b/testing/php-suhosin/0001-php_flock-undefined-variable-fix.patch
new file mode 100644
index 0000000000..eb08b1f52e
--- /dev/null
+++ b/testing/php-suhosin/0001-php_flock-undefined-variable-fix.patch
@@ -0,0 +1,27 @@
+From 2979ca419e3c38252384e6b4a23c53736645542a Mon Sep 17 00:00:00 2001
+From: "V.Krishn" <vkrishn4@gmail.com>
+Date: Tue, 16 Feb 2016 20:33:31 +0530
+Subject: [PATCH] php_flock undefined variable fix
+
+---
+ log.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/log.c b/log.c
+index eae3841..77cbfa7 100644
+--- a/log.c
++++ b/log.c
+@@ -30,6 +30,9 @@
+ #include <fcntl.h>
+ #include "SAPI.h"
+ #include "ext/standard/datetime.h"
++
++#define LOCK_EX 2
++#define LOCK_UN 3
+ #include "ext/standard/flock_compat.h"
+
+ #ifdef HAVE_SYS_SOCKET_H
+--
+1.7.10.4
+
+
diff --git a/testing/php-suhosin/APKBUILD b/testing/php-suhosin/APKBUILD
new file mode 100644
index 0000000000..eb22cc7884
--- /dev/null
+++ b/testing/php-suhosin/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: V.Krishn <vkrishn4@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=php-suhosin
+_pkgreal=suhosin
+pkgver=0.9.38
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP extension SUHOSIN, An advanced protection system for PHP installations"
+url="http://suhosin.org"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="https://download.suhosin.org/$_pkgreal-$_pkgver.tar.gz
+ 0001-php_flock-undefined-variable-fix.patch
+ "
+
+_srcdir="${srcdir}/$_pkgreal-$_pkgver"
+_builddir="${srcdir}"/$_pkgreal-$_pkgver
+prepare() {
+ cd "$_srcdir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php/conf.d/$_pkgreal.ini
+}
+
+md5sums="0c26402752b0aff69e4b891f062a52bf suhosin-0.9.38.tar.gz
+c7b5679b138f3605f20a4c4b5742b759 0001-php_flock-undefined-variable-fix.patch"
+sha256sums="c02d76c4e7ce777910a37c18181cb67fd9e90efe0107feab3de3131b5f89bcea suhosin-0.9.38.tar.gz
+aeaf1969d67b954a155fc3eb303c47be66a447768ef90712c0efd887fa4c3c68 0001-php_flock-undefined-variable-fix.patch"
+sha512sums="cc4eb38b5d6673cc3f2dc395e5a8b5461d3221019ac9849b747b6d5bae423cd5bd01a75b9432414dc7c26c78bab9f2381a5414712a6906a999f3ec9dc77ebc45 suhosin-0.9.38.tar.gz
+d9bd1df73d33014d8e35e5094072e7b4aae2347f83154c0162880bbb2a2463e10d18709aa0fe685342831efdfe06a67886e25db9a9f059d1e0747e8b83781df4 0001-php_flock-undefined-variable-fix.patch"