aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-06 12:14:09 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-06 13:26:29 +0200
commitc61d1741d2a00578169dbcdbf3de31a82600ec3c (patch)
tree19909dadeb6899f2950980de92a6a71442c85086 /testing
parent4366f647d1a4b463a916656965f84081f3b38bfa (diff)
downloadaports-c61d1741d2a00578169dbcdbf3de31a82600ec3c.tar.bz2
aports-c61d1741d2a00578169dbcdbf3de31a82600ec3c.tar.xz
testing/pgexportdoc: new aport
https://github.com/okbob/pgexportdoc CLI tool for export XML, TEXT and BYTEA documents from PostgreSQL
Diffstat (limited to 'testing')
-rw-r--r--testing/pgexportdoc/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/pgexportdoc/APKBUILD b/testing/pgexportdoc/APKBUILD
new file mode 100644
index 0000000000..b30674ebc2
--- /dev/null
+++ b/testing/pgexportdoc/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=pgexportdoc
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="CLI tool for export XML, TEXT and BYTEA documents from PostgreSQL"
+url="https://github.com/okbob/pgexportdoc"
+arch="all"
+license="BSD"
+makedepends="libedit-dev libxml2-dev postgresql-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/okbob/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ ./pgexportdoc -V
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e3589e3a2fe7d77230160711e921908c417e693fd802ee1f803bd2738f38e334d3a3d8df47aa90153c729e6f7f45867c3864909ad609d79b99acfd2e8bf48f55 pgexportdoc-0.1.1.tar.gz"