aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPureTryOut <bart.ribbers@openmailbox.org>2017-08-03 22:40:59 +0200
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-03 20:41:04 +0000
commitc72f2efd6700d1007e10b619589292248347dbdd (patch)
tree119425b631111ec73d6ae6c40a2210acccbc80f3 /testing
parente259406f44e50c905d90f1a6576a72099a90862e (diff)
downloadaports-c72f2efd6700d1007e10b619589292248347dbdd.tar.bz2
aports-c72f2efd6700d1007e10b619589292248347dbdd.tar.xz
testing/consolekit2: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/consolekit2/APKBUILD38
-rw-r--r--testing/consolekit2/ac_disable_static.patch13
2 files changed, 51 insertions, 0 deletions
diff --git a/testing/consolekit2/APKBUILD b/testing/consolekit2/APKBUILD
new file mode 100644
index 0000000000..99f03a34c5
--- /dev/null
+++ b/testing/consolekit2/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Bart Ribbers <bart.ribbers@openmailbox.org>
+# Maintainer: Bart Ribbers <bart.ribbers@openmailbox.org>
+pkgbase=ConsoleKit2
+pkgname=consolekit2
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A framework for defining and tracking users, login sessions, and seats. "
+arch=all
+url="https://consolekit2.github.io/ConsoleKit2"
+license=GPL2
+depends="gettext glib zlib polkit eudev libdrm cgmanager libnih"
+makedepends="git automake autoconf gettext-dev glib-dev zlib-dev libxslt-dev
+ polkit-dev eudev-dev libdrm-dev cgmanager-dev libnih-dev libtool
+ xorg-server-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz
+ ac_disable_static.patch"
+subpackages="$pkgname-doc $pkgname-lang"
+
+prepare() {
+ cd "$srcdir"/$pkgbase-$pkgver
+ patch -p1 < "$srcdir"/ac_disable_static.patch
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$srcdir"/$pkgbase-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgbase-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="30f2ceec14044669f40676e9b17513874350e2b70f0a918be934f7e64309c8595dbec4ac0937044c98dda51eb97c99443dc9d1de33f08365d72da8600296ad78 consolekit2-1.2.0.tar.gz
+0f628fd1589b1790ad9adcb2278de504b75cc6b4ec7284a1cbda44ebd34b9966014989f47f343cb936d8503acc4eeec43ddff07cb11f55388e47256b8420e2e8 ac_disable_static.patch"
diff --git a/testing/consolekit2/ac_disable_static.patch b/testing/consolekit2/ac_disable_static.patch
new file mode 100644
index 0000000000..38d6f12ac1
--- /dev/null
+++ b/testing/consolekit2/ac_disable_static.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 071a0d8..7469697 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,6 @@ AC_SEARCH_LIBS([strerror],[cposix])
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_HEADER_STDC
+-AC_DISABLE_STATIC
+-LT_INIT
++LT_INIT([disable-static])
+ AC_HEADER_STDC
+ AC_FUNC_FORK