aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-28 23:02:01 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 23:02:40 +0200
commitc7aa3b22f294a0f4031681881630c8dbf5aeb5e6 (patch)
tree4c202b06e7182b2ed2d72425d7454c3811e6db5b /testing
parent8a538c5f1ed5652acd38513ebc44e7e984657c97 (diff)
downloadaports-c7aa3b22f294a0f4031681881630c8dbf5aeb5e6.tar.bz2
aports-c7aa3b22f294a0f4031681881630c8dbf5aeb5e6.tar.xz
testing/tarantool: disable on aarch64, armhf (build only on x86_64)
Fails to build on aarch64: cd /home/buildozer/aports/testing/tarantool/src/tarantool-1.7.4.335/test/unit && /usr/bin/cmake -E cmake_link_script CMakeFiles/coio.test.dir/link.txt --verbose=1 /usr/bin/c++ -Os -fexceptions -funwind-tables -fno-common -fopenmp -std=c++11 -Wall -Wextra -Wno-strict-aliasing -Wno-char-subscripts -Wno-format-truncation -Wno-invalid-offsetof -Wno-unused-parameter -Wno-unused -Wno-tautological-compare -O3 -DNDEBUG -rdynamic CMakeFiles/coio.test.dir/coio.cc.o CMakeFiles/coio.test.dir/__/__/src/iobuf.cc.o -o coio.test ../../src/libcore.a ../../libeio.a ../../src/lib/bit/libbit.a ../../src/liburi.a libunit.a ../../src/lib/salad/libsalad.a ../../src/lib/small/libsmall.a -lpthread ../../libev.a -lm -Wl,-Bstatic -lcoro -Wl,-Bdynamic ../../src/libcore.a(fiber.c.o): In function `fiber_schedule_wakeup': fiber.c:(.text+0xb0): undefined reference to `coro_transfer' ../../src/libcore.a(fiber.c.o): In function `fiber_loop': fiber.c:(.text+0x658): undefined reference to `coro_transfer' ../../src/libcore.a(fiber.c.o): In function `fiber_call': fiber.c:(.text+0xf80): undefined reference to `coro_transfer' ../../src/libcore.a(fiber.c.o): In function `fiber_start': fiber.c:(.text+0x1038): undefined reference to `coro_transfer' ../../src/libcore.a(fiber.c.o): In function `fiber_reschedule': fiber.c:(.text+0x1368): undefined reference to `coro_transfer' ../../src/libcore.a(fiber.c.o):fiber.c:(.text+0x1560): more undefined references to `coro_transfer' follow collect2: error: ld returned 1 exit status make[2]: *** [test/unit/CMakeFiles/coio.test.dir/build.make:133: test/unit/coio.test] Error 1
Diffstat (limited to 'testing')
-rw-r--r--testing/tarantool/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/tarantool/APKBUILD b/testing/tarantool/APKBUILD
index 2c448cdf79..46085fbc79 100644
--- a/testing/tarantool/APKBUILD
+++ b/testing/tarantool/APKBUILD
@@ -7,7 +7,11 @@ _series=${pkgver%.*}; _series=${_series%.*} # x.y
pkgrel=2
pkgdesc="Lua application server integrated with a database management system"
url="https://tarantool.org"
-arch="all !x86 !ppc64le !s390x" # bundled LuaJIT is not supported on these
+# x86, aarch64: fails to build
+# armhf: zstd not available (fails to build)
+# ppc64le: not supported by LuaJIT w/o patches
+# s390x: not supported by LuaJIT
+arch="x86_64"
license="BSD-2-Clause MIT Public-Domain"
pkgusers="$pkgname"
pkggroups="$pkgname"