aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-24 08:27:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-24 08:27:31 +0000
commitd09e4350e630d5a484b32dc3e26f8553497c35ea (patch)
treec0c9fe9601da32e09692b14788f3fc896ae45732 /testing
parent9c6f83066a4455ab91d8eadac2d6bf1a9ee3e37b (diff)
downloadaports-d09e4350e630d5a484b32dc3e26f8553497c35ea.tar.bz2
aports-d09e4350e630d5a484b32dc3e26f8553497c35ea.tar.xz
testing/py-jsonrpclib: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py-jsonrpclib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-jsonrpclib/APKBUILD b/testing/py-jsonrpclib/APKBUILD
new file mode 100644
index 0000000000..e0a4ebb53b
--- /dev/null
+++ b/testing/py-jsonrpclib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-jsonrpclib
+pkgver=0.1.7
+pkgrel=0
+pkgdesc="A Python JSON-RPC over HTTP that mirrors xmlrpclib syntax"
+url="https://github.com/joshmarshall/jsonrpclib"
+arch="noarch"
+license="APACHE2.0"
+depends=""
+depends_dev=""
+makedepends="$depends_dev python-dev py-setuptools"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/joshmarshall/${pkgname/py-/}/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/${pkgname/py-/}-$pkgver
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a071d3bb3f56b9bce4e3740f87784b0a py-jsonrpclib-0.1.7.tar.gz"
+sha256sums="28355fb625fba393c458a532baa21e6ec063b394a27e5c0abdbc73e6c7e07488 py-jsonrpclib-0.1.7.tar.gz"
+sha512sums="caa315879faac986c14a15cd87591ea2823405f2ea0731962c37147378f77bcfd260c6e7900bc128392332b27e2c0ae23cab9cb6150adb39924f9a369405b2ec py-jsonrpclib-0.1.7.tar.gz"