aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:31:46 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:59:18 +0200
commite7d9d6353d4454eef61ba3262f05ccb7b525c0b9 (patch)
treefbf6f99c78062d34f7b9712cda660b1514a68d92 /testing
parent3af008e6d6ebf8eab9b779e015f954d1e1284848 (diff)
downloadaports-e7d9d6353d4454eef61ba3262f05ccb7b525c0b9.tar.bz2
aports-e7d9d6353d4454eef61ba3262f05ccb7b525c0b9.tar.xz
testing/py3-pygithub: new aport
https://github.com/PyGithub/PyGithub Typed interactions with the GitHub API v3
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pygithub/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-pygithub/APKBUILD b/testing/py3-pygithub/APKBUILD
new file mode 100644
index 0000000000..8a7f7ab5ac
--- /dev/null
+++ b/testing/py3-pygithub/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-pygithub
+_pkgname=PyGithub
+pkgver=1.40
+pkgrel=0
+pkgdesc="Typed interactions with the GitHub API v3"
+url="https://github.com/PyGithub/PyGithub"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3 py3-jwt py3-requests"
+makedepends="python3-dev"
+source="https://github.com/PyGithub/PyGithub/archive/v$pkgver/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -R "$pkgdir"/usr/lib/python3.*/site-packages/github/tests
+}
+
+sha512sums="e8719017ce04db2c25ab8059b124a43a3688d4775861b80a0bcc7a194eaf43cd942eba1da199b76ef35c5bcde364708586c09630a7fac5642867b5a62985efad PyGithub-1.40.tar.gz"