aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-20 09:05:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 10:27:33 +0000
commitec8ac62eec56b2a76a2e56c991e57107932e53ef (patch)
tree2058492a3730c0ca4d8b9b31781c8d231f2ab787 /testing
parent9ce8f811e2b3e053a9e96393050dbcd980d3e6a2 (diff)
downloadaports-ec8ac62eec56b2a76a2e56c991e57107932e53ef.tar.bz2
aports-ec8ac62eec56b2a76a2e56c991e57107932e53ef.tar.xz
testing/perl-module-build-tiny: new aport
A tiny replacement for Module::Build http://search.cpan.org/dist/Module-Build-Tiny/
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-module-build-tiny/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/perl-module-build-tiny/APKBUILD b/testing/perl-module-build-tiny/APKBUILD
new file mode 100644
index 0000000000..d3b5305b78
--- /dev/null
+++ b/testing/perl-module-build-tiny/APKBUILD
@@ -0,0 +1,44 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-module-build-tiny
+_pkgreal=Module-Build-Tiny
+pkgver=0.030
+pkgrel=0
+pkgdesc="A tiny replacement for Module::Build"
+url="http://search.cpan.org/dist/Module-Build-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-extutils-installpaths perl-extutils-config perl-extutils-helpers perl-test-harness"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL --installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install --destdir="$pkgdir" --create_packlist=0 || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="1c54bf4c602eec87f98950314699402e Module-Build-Tiny-0.030.tar.gz"
+sha256sums="dfd418ad0e8290cf645ab11be209a1bf6865e5a562c5a1592da99d5fd24718a8 Module-Build-Tiny-0.030.tar.gz"
+sha512sums="654d05e6a88fd41aef1a4676707d038d119b2fc33afa98948cafe1d40bc89957cbc99a80a0260851e31678d426e9861a69a976bf21208d1ee58dc7fa7a3b6162 Module-Build-Tiny-0.030.tar.gz"