aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-07-28 09:17:16 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-07-28 09:17:16 +0000
commitf5e0a91cafa6d3a34f630c532eeb59a18cd990e3 (patch)
tree7c388d9ce407d864bda38d7d7a6596b668a596ff /testing
parent707686fb92ef0923042409d385e760dfb67facd6 (diff)
parent76ef3b81d022383c1f3c0b3723e4a9b4473bb4d9 (diff)
downloadaports-f5e0a91cafa6d3a34f630c532eeb59a18cd990e3.tar.bz2
aports-f5e0a91cafa6d3a34f630c532eeb59a18cd990e3.tar.xz
Merge git://github.com/blinkkin/aports
Diffstat (limited to 'testing')
-rw-r--r--testing/hessling-editor/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/hessling-editor/APKBUILD b/testing/hessling-editor/APKBUILD
new file mode 100644
index 0000000000..001c9726b0
--- /dev/null
+++ b/testing/hessling-editor/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor:
+# Maintainer:
+pkgname=hessling-editor
+_pkgname=THE
+pkgver=3.3_rc1
+_pkgver=3.3RC1
+pkgrel=0
+pkgdesc="Powerful text editor modelled on the XEDIT with the best features of Kedit."
+url="http://hessling-editor.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=
+makedepends="ncurses-dev regina-rexx-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$_pkgname-$_pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --with-rexx=regina --with-ncurses --prefix=/usr || return 1
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e46b63e533bc458f6f701983b7f2150b THE-3.3RC1.tar.gz"