aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/chromaprint
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/chromaprint
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/chromaprint')
-rw-r--r--unmaintained/chromaprint/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/chromaprint/APKBUILD b/unmaintained/chromaprint/APKBUILD
new file mode 100644
index 0000000000..7b0d124b5b
--- /dev/null
+++ b/unmaintained/chromaprint/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=chromaprint
+pkgver=1.2
+pkgrel=1
+pkgdesc="Library that implements a custom algorithm for extracting fingerprints from any audio source"
+url="http://acoustid.org/chromaprint/"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="ffmpeg-dev"
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-dev"
+source="https://bitbucket.org/acoustid/chromaprint/downloads/chromaprint-$pkgver.tar.gz"
+
+_builddir="$srcdir"/chromaprint-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_EXAMPLES=ON \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="748da044a8f0ee5f31edec8b67045b3e chromaprint-1.2.tar.gz"
+sha256sums="822b8949a322ac04c6f8a3ed78f5e689bcc493c6ca0972bf627c913c8430031a chromaprint-1.2.tar.gz"
+sha512sums="dc61db8894a20df3d7e7317cd7cd97148c19be5854dd66409341cb8e47c045e1c632b254e14a869279983a5af2cc6f9effea21b77a63dff729511e6144439cbb chromaprint-1.2.tar.gz"