aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/courier-authlib/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/courier-authlib/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/courier-authlib/APKBUILD')
-rw-r--r--unmaintained/courier-authlib/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/unmaintained/courier-authlib/APKBUILD b/unmaintained/courier-authlib/APKBUILD
new file mode 100644
index 0000000000..38525d9e0a
--- /dev/null
+++ b/unmaintained/courier-authlib/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Jeff Bilyk <jbilyk@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=courier-authlib
+pkgver=0.66.1
+pkgrel=2
+pkgdesc="Authentication library for courier mailserver"
+url="http://www.courier-mta.org"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="libtool expect gdbm-dev openssl-dev libldap postgresql-dev mariadb-dev perl"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/courier/authlib/$pkgver/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --with-db=gdbm \
+ --with-mailuser=courier \
+ --with-mailgroup=courier \
+ --with-authpwd \
+ --with-authshadow \
+ --with-authldap \
+ --with-authmysql \
+ --with-authpgsql \
+ --with-authuserdb \
+ --with-authcram \
+ --with-authdaemon \
+ --with-authdaemonvar=/var/run/authdaemon
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="123e9429909ed65a23464cb7ecb15cf1 courier-authlib-0.66.1.tar.bz2"
+sha256sums="8f89166f57c8e59f445fe0135da92b95f1c4417896d01eda5e2e94d8ff878fe8 courier-authlib-0.66.1.tar.bz2"
+sha512sums="d2b0c9c92c0af8c596fd9b14337034e2859c4540b5b20523e8dfbec78f54021104b6864c7f3488f518ebfff488b38bdbc26690763175940d12019f5cbc482b33 courier-authlib-0.66.1.tar.bz2"