aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/datacoin-hp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/datacoin-hp
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/datacoin-hp')
-rw-r--r--unmaintained/datacoin-hp/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/datacoin-hp/APKBUILD b/unmaintained/datacoin-hp/APKBUILD
new file mode 100644
index 0000000000..f921f2a505
--- /dev/null
+++ b/unmaintained/datacoin-hp/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=datacoin-hp
+pkgver=0_git20140921
+pkgrel=0
+_commit=791125b901767b9dec40e04f6865181a3276395b
+pkgdesc="High-performance version of datacoin"
+url=https://github.com/foo1inge/datacoin-hp
+arch="x86_64"
+license=MIT
+depends=
+makedepends="boost-dev db-dev gmp-dev miniupnpc-dev openssl-dev"
+install=
+subpackages=
+source=$url/archive/$_commit.zip
+
+_builddir=$srcdir/$pkgname-$_commit/src
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -f makefile.unix BOOST_LIB_SUFFIX=-mt
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m 755 datacoind "$pkgdir/usr/bin/datacoind"
+}
+
+md5sums="f5fc62457bf6d64286eb24d11a4b3169 791125b901767b9dec40e04f6865181a3276395b.zip"
+sha256sums="99c0147bdf838337ff4b6b66519f6e04810b8ff2d88251bcb46e844c4720a507 791125b901767b9dec40e04f6865181a3276395b.zip"
+sha512sums="8925bd53749f5370299c38a90c96be539c8064de4e077cc0f6090353d9484fdcd38236c0da88b9c2d6cfb215d77ad02addd0061ce39f997581251cdcb0a2495a 791125b901767b9dec40e04f6865181a3276395b.zip"