aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dhex
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/dhex
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/dhex')
-rw-r--r--unmaintained/dhex/APKBUILD45
-rw-r--r--unmaintained/dhex/makefile.patch49
2 files changed, 94 insertions, 0 deletions
diff --git a/unmaintained/dhex/APKBUILD b/unmaintained/dhex/APKBUILD
new file mode 100644
index 0000000000..edbbb1271f
--- /dev/null
+++ b/unmaintained/dhex/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhex
+pkgver=0.68
+pkgrel=1
+pkgdesc="Ncurses hex editor"
+url="http://www.dettus.net/dhex/"
+arch="all"
+license="GPL2+"
+depends=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.dettus.net/dhex/dhex_$pkgver.tar.gz
+ makefile.patch"
+_builddir="$srcdir"/dhex_$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" \
+ mandir=/usr/share/man \
+ prefix=/usr || return 1
+}
+
+md5sums="5109b3d50053553e41d75c8e5c0a0175 dhex_0.68.tar.gz
+de16e09d3b416650d84ef39235cd2917 makefile.patch"
+sha256sums="126c34745b48a07448cfe36fe5913d37ec562ad72d3f732b99bd40f761f4da08 dhex_0.68.tar.gz
+e29f8279a25c6bcc6f43f61c80d08948e40cea67866eed5e745ea5f63af3d291 makefile.patch"
+sha512sums="9397ec0574652022387f4108613f839b9262841c436079249fb325011b0a0e3c5bbd32d323f37b0f30e643f7060c1275337710c237ab68fb0c3f8096651a2421 dhex_0.68.tar.gz
+0e2aa694723afd859f97f8ea02a79fec02bcbd70b9f4bd8ba1e33743f1fa72fa8810bfb7bac2c7a855bf407cd7c0cbb3ef82c7fea1fcb19a2701ab2d55baf7e3 makefile.patch"
diff --git a/unmaintained/dhex/makefile.patch b/unmaintained/dhex/makefile.patch
new file mode 100644
index 0000000000..9e7788b409
--- /dev/null
+++ b/unmaintained/dhex/makefile.patch
@@ -0,0 +1,49 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1,12 +1,22 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
++CC?= gcc
++LDFLAGS?= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+ CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
++CFLAGS?= -O3 -Wall -std=c99
+ #CFLAGS+= -ffunction-sections -fdata-sections
+ #LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+-DESTDIR= /usr/local/
+
++prefix= /usr/local
++bindir= $(prefix)/bin
++mandir= $(prefix)/man
++man1dir= $(mandir)/man1
++man5dir= $(mandir)/man5
++DESTDIR=
++
++MKDIR_P= install -d
++INSTALL= install
++
++
+ OFILES=buffers.o \
+ configfile.o \
+ correlation.o \
+@@ -27,14 +37,11 @@
+ $(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+
+ install:all
+- strip dhex
+- cp dhex $(DESTDIR)/bin
+- cp dhex.1 $(DESTDIR)/man/man1
+- cp dhexrc.5 $(DESTDIR)/man/man5
+- cp dhex_markers.5 $(DESTDIR)/man/man5
+- cp dhex_searchlog.5 $(DESTDIR)/man/man5
+-
+-
++ $(MKDIR_P) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) $(DESTDIR)$(man5dir)
++ $(INSTALL) -m755 dhex $(DESTDIR)$(bindir)
++ $(INSTALL) -m644 dhex.1 $(DESTDIR)$(man1dir)
++ $(INSTALL) -m644 dhexrc.5 dhex_markers.5 dhex_searchlog.5 \
++ $(DESTDIR)$(man5dir)
+
+ .c.o:
+ $(CC) $< -c -I. $(CPPFLAGS) $(CFLAGS) $(OPTIONS)