aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ethumb/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ethumb/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ethumb/APKBUILD')
-rw-r--r--unmaintained/ethumb/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/ethumb/APKBUILD b/unmaintained/ethumb/APKBUILD
new file mode 100644
index 0000000000..ca13a103cd
--- /dev/null
+++ b/unmaintained/ethumb/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ethumb
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="A thumbnail generation library"
+url="http://trac.enlightenment.org/e/wiki/Ethumb"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="eina-dev evas-dev ecore-dev edje-dev e_dbus-dev libexif-dev
+ emotion-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/ethumb-$pkgver.tar.gz"
+
+_builddir="$srcdir"/ethumb-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d71a6fbcce2c6a8f46ea9b9b9d53cbab ethumb-1.7.9.tar.gz"
+sha256sums="a97c39a9184ec7e1b352a7f251d97992b8082e3a0d6735ea1f34e4e40129a12f ethumb-1.7.9.tar.gz"
+sha512sums="70b77a902bf1005d5e5d9a9c3531e9d119e083b7a94e9e28750d3005bc386bd1d57bc2111d42c19924c1fc0a10ea0bfe6c5d1d8ae679c9546157c098991a5795 ethumb-1.7.9.tar.gz"