aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/evilwm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/evilwm
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/evilwm')
-rw-r--r--unmaintained/evilwm/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/evilwm/APKBUILD b/unmaintained/evilwm/APKBUILD
new file mode 100644
index 0000000000..c5d0a2c6a5
--- /dev/null
+++ b/unmaintained/evilwm/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=evilwm
+pkgver=1.1.0
+_myver="${pkgver//_/}"
+pkgrel=0
+pkgdesc="A minimalist window manager for the X Window System"
+url="http://www.6809.org.uk/evilwm/"
+arch="all"
+license="custom"
+depends=""
+depends_dev=""
+makedepends="libx11-dev libxext-dev libxrandr-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.6809.org.uk/evilwm/evilwm-$_myver.tar.gz"
+
+_builddir="$srcdir"/evilwm-$_myver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5f14cc3019320860c85bb07c60a76bd7 evilwm-1.1.0.tar.gz"
+sha256sums="cdc763c875b64ee3734f3cb764249e91ec659f550177ec1bb564304260ef0c75 evilwm-1.1.0.tar.gz"
+sha512sums="e0df42422431698623cc41ccec7b626cc59f7ef4c17a90169e6410e374cc602de12fc075d42e7ed5699b2ca363c22a9e5361117a8748aceca9c66175fde46d25 evilwm-1.1.0.tar.gz"