aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/exfat-utils/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/exfat-utils/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/exfat-utils/APKBUILD')
-rw-r--r--unmaintained/exfat-utils/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/unmaintained/exfat-utils/APKBUILD b/unmaintained/exfat-utils/APKBUILD
new file mode 100644
index 0000000000..8ae74f06aa
--- /dev/null
+++ b/unmaintained/exfat-utils/APKBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=exfat-utils
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Utilities for exFAT file system"
+url="https://github.com/relan/exfat"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/relan/exfat/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/exfat-utils-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ ./configure --prefix=/usr --sbindir=/usr/bin || return 1
+ make CCFLAGS="${CFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}" \
+ || return 1
+
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+
+ # Install man pages
+ install -Dm444 dump/dumpexfat.8 "${pkgdir}/usr/share/man/man8/dumpexfat.8" \
+ || return 1
+ install -m444 fsck/exfatfsck.8 "${pkgdir}/usr/share/man/man8" \
+ || return 1
+ install -m444 mkfs/mkexfatfs.8 "${pkgdir}/usr/share/man/man8" \
+ || return 1
+ install -m444 label/exfatlabel.8 "${pkgdir}/usr/share/man/man8" \
+ || return 1
+}
+
+md5sums="ae918dd8a360f1da2299f3c748c53253 exfat-utils-1.2.2.tar.gz"
+sha256sums="60e33b51db5a8f79b035031bc61b120cdac3075dd27fad156ece4feeb82871f7 exfat-utils-1.2.2.tar.gz"
+sha512sums="bd3c4d57b05aee7064e05a8af7ff8d7a1bf7b9a891d804c45fb6c5fcc19d877b75a25c32cfee462133f203a1bead3a65c40d5e32061b5dc4943f36c2a961c2b8 exfat-utils-1.2.2.tar.gz"