aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gtk-equinox-engine
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/gtk-equinox-engine
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/gtk-equinox-engine')
-rw-r--r--unmaintained/gtk-equinox-engine/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/unmaintained/gtk-equinox-engine/APKBUILD b/unmaintained/gtk-equinox-engine/APKBUILD
new file mode 100644
index 0000000000..3f5b3ad2bd
--- /dev/null
+++ b/unmaintained/gtk-equinox-engine/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gtk-equinox-engine
+pkgver=1.50
+pkgrel=0
+pkgdesc="enhanced cairo-based GTK+ engine"
+url="http://gnome-look.org/content/show.php/Equinox+GTK+Engine"
+license="GPL"
+arch="all"
+depends=
+makedepends="gtk+-dev"
+install=
+subpackages=
+source="http://gnome-look.org/CONTENT/content-files/121881-equinox-$pkgver.tar.gz"
+
+_builddir="$srcdir"/equinox-${pkgver}
+
+prepare() {
+ cd "$srcdir"
+
+ msg "Unpacking GTK+ engine"
+ tar zxf equinox-gtk-engine.tar.gz
+
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/themes
+ cd "$pkgdir"/usr/share/themes
+
+ msg "Unpacking themes"
+ tar zxf "$srcdir"/equinox-themes.tar.gz
+
+}
+
+md5sums="f5ab68e50e128ee5186265b80d5cf1bd 121881-equinox-1.50.tar.gz"