aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ibniz
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ibniz
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ibniz')
-rw-r--r--unmaintained/ibniz/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/ibniz/APKBUILD b/unmaintained/ibniz/APKBUILD
new file mode 100644
index 0000000000..a1ef5ff7fe
--- /dev/null
+++ b/unmaintained/ibniz/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=ibniz
+pkgver=1.18
+pkgrel=0
+pkgdesc="A virtual machine designed for extremely compact low-level audiovisual programs"
+url="http://pelulamu.net/ibniz/"
+arch="all"
+license="zlib"
+depends=""
+depends_dev="sdl-dev"
+makedepends="$depends_dev"
+install=""
+source="${url}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 ibniz "$pkgdir/usr/bin/ibniz"
+ install -D -m644 licence.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+
+md5sums="81ee96b253111cfe2abdc7a843757287 ibniz-1.18.tar.gz"
+sha256sums="e2f292641a67abd477fac8f2c455fa1579ba854c1f15152a41fef48fd46c6481 ibniz-1.18.tar.gz"
+sha512sums="63448e3eb639a831b847cc3a737040a661ff4107e53ff70b9c33ba951c584ca903729547efd27afff9ac0b9e25a315a1d36670a4f4722c3d2287f375cb1bd760 ibniz-1.18.tar.gz"