aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libdvdcss/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libdvdcss/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libdvdcss/APKBUILD')
-rw-r--r--unmaintained/libdvdcss/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/libdvdcss/APKBUILD b/unmaintained/libdvdcss/APKBUILD
new file mode 100644
index 0000000000..fcf43b45ec
--- /dev/null
+++ b/unmaintained/libdvdcss/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libdvdcss
+pkgver=1.2.13
+pkgrel=0
+pkgdesc="A library to access (encrypted) DVDs like a block device"
+url="http://www.videolan.org/developers/libdvdcss.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.videolan.org/pub/libdvdcss/$pkgver/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/libdvdcss-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+ make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="53cfc52a60a156763c425572e5179273 libdvdcss-1.2.13.tar.bz2"
+sha256sums="84f1bba6cfef1df87f774fceaefc8e73c4cda32e8f6700b224ad0acb5511ba2c libdvdcss-1.2.13.tar.bz2"
+sha512sums="b7d912ef87854bca052c2f38709d49eeb72be9148b6598a7f71f9ccb1ad7f43a521f9533821fbd8d7ef16e2c36fe140209c9183f5ca91e8f806150cc16645717 libdvdcss-1.2.13.tar.bz2"