aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libqb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libqb
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libqb')
-rw-r--r--unmaintained/libqb/APKBUILD54
-rw-r--r--unmaintained/libqb/fix-headers.patch10
2 files changed, 64 insertions, 0 deletions
diff --git a/unmaintained/libqb/APKBUILD b/unmaintained/libqb/APKBUILD
new file mode 100644
index 0000000000..fa0207e83b
--- /dev/null
+++ b/unmaintained/libqb/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libqb
+pkgver=0.17.1
+pkgrel=0
+pkgdesc="An IPC library for high performance servers"
+url="https://github.com/clusterlabs/libqb/wiki"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://fedorahosted.org/releases/q/u/quarterback/libqb-$pkgver.tar.xz
+ fix-headers.patch
+ "
+
+_builddir="$srcdir"/libqb-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5770b343baa4528f6fec90120ec55048 libqb-0.17.1.tar.xz
+1825f2c3b4405ccc5795fa2b6bbfce32 fix-headers.patch"
+sha256sums="7a2115f83bfe20eaa5f2e4ed235e8f2994235d3b87e3e5ca41ba47b320f12e29 libqb-0.17.1.tar.xz
+3be824e898e5b32d2a2869ebad3e930606b4bcee850f437e9bd9d126c28cbc4e fix-headers.patch"
+sha512sums="9705b291a61ca278fd0c9ab631af2cb844cdfc73b19501dd2e12eb162b37f0eded800860127a8a5c5c7c2a0e8db53e4780d3ab9697b099f4560a9a87aa8ec9ca libqb-0.17.1.tar.xz
+1b32bb6c82477b00434644b21e1ae450b9e5f5d3e4f6fd0428aafa117f7f129bfd94412544472affe0a273113222d238264da9bb874a25918fbeb2c4938e6d56 fix-headers.patch"
diff --git a/unmaintained/libqb/fix-headers.patch b/unmaintained/libqb/fix-headers.patch
new file mode 100644
index 0000000000..474f4c2fd5
--- /dev/null
+++ b/unmaintained/libqb/fix-headers.patch
@@ -0,0 +1,10 @@
+--- ./include/qb/qbipcs.h.orig
++++ ./include/qb/qbipcs.h
+@@ -31,6 +31,7 @@
+
+ #include <stdlib.h>
+ #include <sys/uio.h>
++#include <sys/stat.h>
+ #include <qb/qbipc_common.h>
+ #include <qb/qbhdb.h>
+ #include <qb/qbloop.h>