aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libubox
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libubox
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libubox')
-rw-r--r--unmaintained/libubox/APKBUILD55
-rw-r--r--unmaintained/libubox/includes.patch11
-rw-r--r--unmaintained/libubox/json-pkgconf-detect.patch11
3 files changed, 77 insertions, 0 deletions
diff --git a/unmaintained/libubox/APKBUILD b/unmaintained/libubox/APKBUILD
new file mode 100644
index 0000000000..87c1e1978a
--- /dev/null
+++ b/unmaintained/libubox/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=libubox
+pkgver=0_git20150921
+pkgrel=1
+pkgdesc="C utility functions for OpenWrt"
+url="https://github.com/xfguo/libubox"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev autoconf cmake json-c-dev"
+subpackages="$pkgname-dev"
+install=
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ json-pkgconf-detect.patch
+ includes.patch
+ "
+giturl="https://github.com/xfguo/libubox.git"
+disturl="dev.alpinelinux.org:/archive/$pkgname"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake CMakeLists.txt -DBUILD_LUA=OFF -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="ec55e215665beb746086c733d2b270e2 libubox-0_git20150921.tar.gz
+eb218033a9c32ea192e5b7b7950588e2 json-pkgconf-detect.patch
+5abfaee650e28f4e1211633a84d88d47 includes.patch"
+sha256sums="df7ef8903c81b87408f8bca0158c7a5bb146c999dbd5def4b27a919b9ea60fe7 libubox-0_git20150921.tar.gz
+891e69fe1d5d5ca9f8a70cc73c4a066d6f11437372cd1f61de6e9f0d5da1eafe json-pkgconf-detect.patch
+0bc997c6d7355c30f43f3168caaad5f8b7e9b58b4e909d6b0c9dbe5c86d153e3 includes.patch"
+sha512sums="db2ecc70ab84781d5ca96ae18fc51decea95a236c42efab943bb148b91fbc65ca60729360d6c7bd8e8655ab373bfb07cabf0845954a74adee8a077f0535be45d libubox-0_git20150921.tar.gz
+a7ad77529f9976d9e991f72009c851743d8ff7435d2a831bb14fe929834ae59b5afbfb158c5faca4c4a6edd7076bb533875813d95e3672f065474dc4a63323a2 json-pkgconf-detect.patch
+9db73110f57f33ce08f078cafb7eff4a22905415391d5d7a2bc69651517f714fb042b4a5c7f975f4b0d2e2d1193b593af0910f544309bf7eb70c5d7db4d2c212 includes.patch"
diff --git a/unmaintained/libubox/includes.patch b/unmaintained/libubox/includes.patch
new file mode 100644
index 0000000000..2ba75aaf1b
--- /dev/null
+++ b/unmaintained/libubox/includes.patch
@@ -0,0 +1,11 @@
+--- a/blobmsg_json.h
++++ b/blobmsg_json.h
+@@ -19,7 +19,7 @@
+ #ifdef JSONC
+ #include <json.h>
+ #else
+- #include <json/json.h>
++ #include <json-c/json.h>
+ #endif
+
+ #include <stdbool.h>
diff --git a/unmaintained/libubox/json-pkgconf-detect.patch b/unmaintained/libubox/json-pkgconf-detect.patch
new file mode 100644
index 0000000000..c566fd2b4a
--- /dev/null
+++ b/unmaintained/libubox/json-pkgconf-detect.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,7 +13,7 @@
+ ENDIF()
+
+ INCLUDE(FindPkgConfig)
+-PKG_CHECK_MODULES(JSONC json-c json)
++PKG_CHECK_MODULES(JSONC json-c)
+ IF(JSONC_FOUND)
+ ADD_DEFINITIONS(-DJSONC)
+ INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})