aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libx86/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libx86/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libx86/APKBUILD')
-rw-r--r--unmaintained/libx86/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/libx86/APKBUILD b/unmaintained/libx86/APKBUILD
new file mode 100644
index 0000000000..0bb12c5b21
--- /dev/null
+++ b/unmaintained/libx86/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libx86
+pkgver=1.1
+pkgrel=0
+pkgdesc="Library for making real-mode x86 calls"
+url="http://www.codon.org.uk/~mjg59/libx86"
+arch="x86 x86_64"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.codon.org.uk/~mjg59/libx86/downloads/libx86-$pkgver.tar.gz
+ libx86-add-pkgconfig.patch
+ libx86-mmap-offset.patch
+ "
+
+_builddir="$srcdir"/libx86-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make BACKEND=x86emu || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="41bee1f8e22b82d82b5f7d7ba51abc2a libx86-1.1.tar.gz
+7958f84486ebe60cebd85ae3807c5e58 libx86-add-pkgconfig.patch
+cfa7e8b178d2d14431dc0c3e9d5f842d libx86-mmap-offset.patch"