aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lwm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lwm
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lwm')
-rw-r--r--unmaintained/lwm/APKBUILD42
-rw-r--r--unmaintained/lwm/no_xmkmf_makefile.patch11
2 files changed, 53 insertions, 0 deletions
diff --git a/unmaintained/lwm/APKBUILD b/unmaintained/lwm/APKBUILD
new file mode 100644
index 0000000000..411291b273
--- /dev/null
+++ b/unmaintained/lwm/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Michael Zhou <zhoumichaely@gmail.com>
+# Maintainer:
+pkgname=lwm
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Lightweight Window Manager that tries to keep out of your face"
+url="http://www.jfc.org.uk/software/lwm.html"
+arch="all"
+license="GPL"
+depends=""
+makedepends="libx11-dev libsm-dev"
+install=""
+subpackages=""
+source="
+ http://www.jfc.org.uk/files/$pkgname/$pkgname-$pkgver.tar.gz
+ no_xmkmf_makefile.patch
+"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -f no_xmkmf_makefile || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin
+ install lwm "$pkgdir"/usr/bin
+}
+
+md5sums="1748722a293e03d632b615275ef84498 lwm-1.2.2.tar.gz
+cbfa8518daed50927fe4cc8ae5d2e550 no_xmkmf_makefile.patch"
diff --git a/unmaintained/lwm/no_xmkmf_makefile.patch b/unmaintained/lwm/no_xmkmf_makefile.patch
new file mode 100644
index 0000000000..6b7ff60f0f
--- /dev/null
+++ b/unmaintained/lwm/no_xmkmf_makefile.patch
@@ -0,0 +1,11 @@
+--- a/no_xmkmf_makefile
++++ b/no_xmkmf_makefile
+@@ -24,7 +24,7 @@
+ #DEFINES = -D_POSIX_C_SOURCE=2
+
+ # Add any strange libraries your system needs here.
+-LDFLAGS = -lXext -lX11 -lICE -lSM
++LDFLAGS = -lX11 -lICE -lSM
+
+ # -----------------------------------------------------------------------------
+