aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/mathomatic
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/mathomatic
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/mathomatic')
-rw-r--r--unmaintained/mathomatic/APKBUILD41
-rw-r--r--unmaintained/mathomatic/busybox.patch11
2 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/mathomatic/APKBUILD b/unmaintained/mathomatic/APKBUILD
new file mode 100644
index 0000000000..7a3ae6050a
--- /dev/null
+++ b/unmaintained/mathomatic/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=mathomatic
+pkgver=16.0.5
+pkgrel=0
+pkgdesc="A software computer algebra system (CAS)"
+url="http://www.mathomatic.org/math/"
+arch="all"
+license="LGPL2+"
+depends="m4"
+depends_dev="readline-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://mathomatic.orgserve.de/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make -f makefile READLINE=1 CC_OPTIMIZE="$CFLAGS" prefix="/usr" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix="/usr" m4install-degrees || return 1
+}
+
+
+md5sums="dd04913a98a5073b56f3bc78a01820f3 mathomatic-16.0.5.tar.bz2"
+sha256sums="976e6fed1014586bcd584e417c074fa86e4ca6a0fcc2950254da2efde99084ca mathomatic-16.0.5.tar.bz2"
+sha512sums="c44c60183442226562df9eefb1d77e5bafd96b7a5d3ad34a76963c586d398647366e782c75ffcf27c2b7d9d4be56678bbbc4d37ac71687a39f04b3fef450cc73 mathomatic-16.0.5.tar.bz2"
diff --git a/unmaintained/mathomatic/busybox.patch b/unmaintained/mathomatic/busybox.patch
new file mode 100644
index 0000000000..07061ca60c
--- /dev/null
+++ b/unmaintained/mathomatic/busybox.patch
@@ -0,0 +1,11 @@
+--- mathomatic-15.7.1.orig/makefile
++++ mathomatic-15.7.1/makefile
+@@ -33,7 +33,7 @@
+ CC ?= gcc # C compiler to use; this statement doesn't work usually, instead using cc.
+ M4 ?= m4 # Change this to gm4 in Unix or a non-GNU system.
+ INSTALL ?= install # Installer utility to use; change to ginstall under Unix.
+-INSTALL_PROGRAM ?= $(INSTALL) -Cv # Command to install executable program files; compares to see if any differences, first.
++INSTALL_PROGRAM ?= $(INSTALL) -c # Command to install executable program files; compares to see if any differences, first.
+ INSTALL_DATA ?= $(INSTALL) -m 0644 # command to install data files
+
+ CC_OPTIMIZE ?= -O3 # Default C compiler optimization flags that are safe.