aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/onesixtyone
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/onesixtyone
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/onesixtyone')
-rw-r--r--unmaintained/onesixtyone/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/onesixtyone/APKBUILD b/unmaintained/onesixtyone/APKBUILD
new file mode 100644
index 0000000000..6768765620
--- /dev/null
+++ b/unmaintained/onesixtyone/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=onesixtyone
+pkgver=0.3.2
+pkgrel=0
+pkgdesc="An efficient SNMP scanner"
+url="http://www.phreedom.org/software/onesixtyone/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.phreedom.org/software/onesixtyone/releases/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+ install -m644 -D "$_builddir"/dict.txt \
+ "$pkgdir"/usr/share/$pkgname/dict.txt || return 1
+}
+
+md5sums="b08ac88615c04fa50d4eeecd75882e3f onesixtyone-0.3.2.tar.gz"
+sha256sums="450806718f72a75ea108e3675ca7856f15c518fcf517df68483c486c39910d02 onesixtyone-0.3.2.tar.gz"
+sha512sums="8756bfd24cc4b164c2288733970d486ab2f81e0eef95e008dd5749d24cfe690ff6fbf9d1d3bf3f1a916da4d7c0e408e9783fda912fc4ac70d190f55d01cac01a onesixtyone-0.3.2.tar.gz"