aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/openslp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/openslp
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/openslp')
-rw-r--r--unmaintained/openslp/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/openslp/APKBUILD b/unmaintained/openslp/APKBUILD
new file mode 100644
index 0000000000..cf5fd38fa0
--- /dev/null
+++ b/unmaintained/openslp/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: k0r10n <k0r10n.dev@gmail.com>
+# Maintainer:
+pkgname=openslp
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Open source implementation of Service Location Protocol"
+url="http://www.openslp.org/"
+arch="all"
+license="BSD"
+depends=
+depends_dev="openssl-dev"
+makedepends="$depends_dev bash"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/project/openslp/${pkgver}/2.0.0%20Release/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="18cf7940bcc444e32592cf34e84f833f openslp-2.0.0.tar.gz"
+sha256sums="924337a2a8e5be043ebaea2a78365c7427ac6e9cee24610a0780808b2ba7579b openslp-2.0.0.tar.gz"
+sha512sums="e7627417d45d5d0cc83d6e13d62fe192702ce7b763f1b4fb51aa5da8285405b16a34c3ac4f0a1ecffdf59557b29ec7d24925941e56ddee277c8897162f597ade openslp-2.0.0.tar.gz"