aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/php-gmagick
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/php-gmagick
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/php-gmagick')
-rw-r--r--unmaintained/php-gmagick/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/unmaintained/php-gmagick/APKBUILD b/unmaintained/php-gmagick/APKBUILD
new file mode 100644
index 0000000000..08e36b01ad
--- /dev/null
+++ b/unmaintained/php-gmagick/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=php-gmagick
+_pkgreal=gmagick
+pkgver=1.1.7_rc3
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP bindings to the GraphicsMagick library"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php-dev autoconf"
+makedepends="$pecldepends graphicsmagick-dev"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php/conf.d/$_pkgreal.ini
+}
+
+md5sums="b11fe7922daf32a2f82956a3501c7c7b gmagick-1.1.7RC3.tgz"
+sha256sums="1d2a35811a29e0744e852dda526f30c8a0cba516ef611758dd5bd4837ecba1fd gmagick-1.1.7RC3.tgz"
+sha512sums="a51f148dc16322bcd5586b4af059389159edab1de4ada5743a5ef6dd8d4f001a21f955dc8fd2dac2969a5048db89e3b8031da3a2f519d59fcb1f8e6afa4d8dd9 gmagick-1.1.7RC3.tgz"