aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/rats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/rats
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/rats')
-rw-r--r--unmaintained/rats/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/rats/APKBUILD b/unmaintained/rats/APKBUILD
new file mode 100644
index 0000000000..ff43ff2502
--- /dev/null
+++ b/unmaintained/rats/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=rats
+pkgver=2.3
+pkgrel=0
+pkgdesc="A tool to find security related programming errors"
+url="https://www.fortify.com/ssa-elements/threat-intelligence/rats.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="expat-dev wget flex"
+install=""
+subpackages="$pkgname-doc"
+source="https://www.fortify.com/downloads2/public/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share/ \
+ --mandir=/usr/share/man
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ ##make DESTDIR="$pkgdir" install || return 1
+ install -Dpm 0755 "$pkgname" "$pkgdir"/usr/bin/$pkgname || return 1
+ mkdir -p "$pkgdir"/usr/share/$pkgname || return 1
+ install -Dm 0644 *.xml "$pkgdir"/usr/share/$pkgname/ || return 1
+}
+
+doc() {
+ # The man page is not picked-up automatically
+ mkdir -p "$subpkgdir"/usr/share/man/man1 || return 1
+ mv "$_builddir"/*.1 "$subpkgdir"/usr/share/man/man1/ || return 1
+}
+
+md5sums="339ebe60fc61789808a457f6f967d226 rats-2.3.tar.gz"