aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/shntool
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/shntool
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/shntool')
-rw-r--r--unmaintained/shntool/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/shntool/APKBUILD b/unmaintained/shntool/APKBUILD
new file mode 100644
index 0000000000..ecdbdf91d2
--- /dev/null
+++ b/unmaintained/shntool/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=shntool
+pkgver=3.0.10
+pkgrel=0
+pkgdesc="A multi-purpose WAVE data processing and reporting utility"
+url="http://www.etree.org/shnutils/shntool/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.etree.org/shnutils/shntool/dist/src/shntool-$pkgver.tar.gz"
+
+_builddir="$srcdir"/shntool-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5d41f8f42c3c15e3145a7a43539c3eae shntool-3.0.10.tar.gz"
+sha256sums="74302eac477ca08fb2b42b9f154cc870593aec8beab308676e4373a5e4ca2102 shntool-3.0.10.tar.gz"
+sha512sums="2150d7123860abb54a56a1615bda991ed3713d73c338723f28b7d01a63c49a47809be16dc57b5b4edeee1567b003f9a4b54945c1cd08440f9503d22b91eaa06d shntool-3.0.10.tar.gz"