aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/spice-vdagent
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/spice-vdagent
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/spice-vdagent')
-rw-r--r--unmaintained/spice-vdagent/APKBUILD60
-rw-r--r--unmaintained/spice-vdagent/fix-memcpy-memset-implicit-declaration.patch11
-rw-r--r--unmaintained/spice-vdagent/spice-vdagentd.initd97
3 files changed, 168 insertions, 0 deletions
diff --git a/unmaintained/spice-vdagent/APKBUILD b/unmaintained/spice-vdagent/APKBUILD
new file mode 100644
index 0000000000..926f355e45
--- /dev/null
+++ b/unmaintained/spice-vdagent/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice-vdagent
+pkgver=0.15.0
+pkgrel=1
+pkgdesc="Agent for Spice guests"
+url="http://spice-space.org/"
+arch="all"
+license="GPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev glib-dev spice-protocol libpciaccess-dev dbus-dev
+ libxrandr-dev libxinerama-dev libxfixes-dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="http://spice-space.org/download/releases/spice-vdagent-$pkgver.tar.bz2
+ "$pkgname"d.initd
+ fix-memcpy-memset-implicit-declaration.patch
+ "
+
+_builddir="$srcdir"/spice-vdagent-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -D "$srcdir/$pkgname"d.initd \
+ "$pkgdir"/etc/init.d/"$pkgname"d || return 1
+}
+
+md5sums="2919ac7a4195b0b4b2588fae90a9241c spice-vdagent-0.15.0.tar.bz2
+038842701e8eb6a2890ecd97f34e9aab spice-vdagentd.initd
+083cdf808a24d1855d09a93a52dbeccd fix-memcpy-memset-implicit-declaration.patch"
+sha256sums="5bae1747307c2f4195f6de97639391be7c6be6c5673fdcc9febed6faca22bd34 spice-vdagent-0.15.0.tar.bz2
+0aab914c3f71d19452969c8bfae64e72bd970df3903e29602217a951e87c0db9 spice-vdagentd.initd
+69bbdffc46bd247f5fdee84e8a06d86b0a59e8dc53e9dc5eb0fd8055d87b9323 fix-memcpy-memset-implicit-declaration.patch"
+sha512sums="7d3bdeca2a8a5a63f817c8b0c1c46508e3238e0d2f3a018e44ffa4c7a2b7d0e82b0a2c37a6f35c59fcb23d89de82312edb689dc1de6fdf659004e640b900f436 spice-vdagent-0.15.0.tar.bz2
+0fc2b0a88b0d8707fa814da1b484888763f2bc51792568a38404a15ba88b4b37e4a9f54bc3452cc4605d0026c2af774bb689df6e56ca14b6fa48be5bc81c5705 spice-vdagentd.initd
+381f974580aa478a9c0a35d7e6cc5bee57903f47929dea143ee2ddda9952d4b3ed6180a2b2e90ef83b01425d46507ea18bba01c42d32739fd0cc85bcbac59537 fix-memcpy-memset-implicit-declaration.patch"
diff --git a/unmaintained/spice-vdagent/fix-memcpy-memset-implicit-declaration.patch b/unmaintained/spice-vdagent/fix-memcpy-memset-implicit-declaration.patch
new file mode 100644
index 0000000000..ad0de924e9
--- /dev/null
+++ b/unmaintained/spice-vdagent/fix-memcpy-memset-implicit-declaration.patch
@@ -0,0 +1,11 @@
+--- spice-vdagent-0.15.0/src/udscs.c
++++ spice-vdagent-0.15.0/src/udscs.c.new
+@@ -26,6 +26,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <errno.h>
+
diff --git a/unmaintained/spice-vdagent/spice-vdagentd.initd b/unmaintained/spice-vdagent/spice-vdagentd.initd
new file mode 100644
index 0000000000..5c04d0242c
--- /dev/null
+++ b/unmaintained/spice-vdagent/spice-vdagentd.initd
@@ -0,0 +1,97 @@
+#!/sbin/openrc-run
+
+# This file is part of spice-vdagent
+# by Stuart Cardall <developer@it-offshore.co.uk>
+
+sockfile="/var/run/spice-vdagentd/spice-vdagent-sock"
+pidfile="/var/run/spice-vdagentd/spice-vdagentd.pid"
+command="/usr/sbin/spice-vdagentd"
+command_args="-X"
+msgfile=/tmp/spice-vdagent.msg
+extra_commands="info"
+
+MODULES="uinput"
+
+depend() {
+ need net
+ need logger
+}
+
+start_pre() {
+ # make sure dir for pidfile exists. /var/run is tmpfs...
+ checkpath --directory ${pidfile%/*}
+ # load userspace input driver for copy & paste support
+ ebegin "Loading uinput kernel module for ${SVCNAME}"
+ for mod in $MODULES; do
+ modprobe -q $mod
+ done
+ eend $?
+ rm -f $sockfile
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start $command --pidfile $pidfile -- $command_args
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile $pidfile
+ eend $? "Failed to stop ${SVCNAME}"
+ ebegin "Unloading uinput kernel module for ${SVCNAME}"
+ for mod in $MODULES; do
+ rmmod $mod
+ done
+ eend $?
+ rm -f $sockfile
+}
+
+info() {
+ cat > $msgfile <<EOF
+By default the daemon is run with $command_args="-X" to disable consolekit
+support & allow a single agent session only. Run without '-X' & install lxdm
+or slim for muliple sessions.
+
+------------------------------------------------------------------------------
+Settings for libvirt:
+------------------------------------------------------------------------------
+<channel type='spicevmc'>
+ <target type='virtio' name='com.redhat.spice.0'/>
+ <address type='virtio-serial' controller='0' bus='0' port='1'/>
+</channel>
+ <input type='tablet' bus='usb'/>
+ <input type='mouse' bus='ps2'/>
+ <input type='keyboard' bus='ps2'/>
+<graphics type='spice' autoport='yes' listen='127.0.0.1'>
+ <listen type='address' address='127.0.0.1'/>
+ <channel name='main' mode='insecure'/>
+ <channel name='record' mode='insecure'/>
+ <image compression='auto_glz'/>
+ <jpeg compression='auto'/>
+ <zlib compression='auto'/>
+ <playback compression='on'/>
+ <streaming mode='filter'/>
+ <mouse mode='client'/>
+ <clipboard copypaste='yes'/>
+ <filetransfer enable='yes'/>
+</graphics>
+<video>
+ <model type='qxl' ram='65536' vram='9216' heads='1'/>
+ <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
+</video>
+
+------------------------------------------------------------------------------
+Settings for /etc/X11/xorg.conf: <install xf86-video-qxl>
+------------------------------------------------------------------------------
+Section "Device"
+ Identifier "Videocard0"
+ Driver "qxl"
+ Option "EnableSurfaces" "0"
+EndSection
+EOF
+
+cat $msgfile
+rm -f $msgfile
+}
+