aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/upgrade-notify
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/upgrade-notify
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/upgrade-notify')
-rw-r--r--unmaintained/upgrade-notify/APKBUILD19
-rw-r--r--unmaintained/upgrade-notify/upgrade-notify.trigger52
2 files changed, 71 insertions, 0 deletions
diff --git a/unmaintained/upgrade-notify/APKBUILD b/unmaintained/upgrade-notify/APKBUILD
new file mode 100644
index 0000000000..901907b1aa
--- /dev/null
+++ b/unmaintained/upgrade-notify/APKBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="upgrade-notify"
+pkgver=0.1
+pkgrel=0
+license="GPL"
+pkgdesc="Get notifications about what services need to restart after an upgrade"
+url="http://git.alpinelinux.org/alpine/tree/testing/upgrade-notify"
+arch=noarch
+triggers="$pkgname.trigger=/etc/init.d:/boot"
+
+build() {
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+
diff --git a/unmaintained/upgrade-notify/upgrade-notify.trigger b/unmaintained/upgrade-notify/upgrade-notify.trigger
new file mode 100644
index 0000000000..0c3cf462f8
--- /dev/null
+++ b/unmaintained/upgrade-notify/upgrade-notify.trigger
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+msg() {
+ local summary="$1"
+ shift
+ echo "" >&2
+ echo " $summary" >&2
+ local i
+ for i; do
+ echo " $i" >&2
+ done
+ echo "" >&2
+}
+
+# compare the timestamp of "started" symlink with timestamp of /etc/init.d
+# if the /etc/init.d/* script is newer than "started" symlink then
+# service was upgraded after service was started
+services=$(find /run/openrc/started -type l | xargs stat -c "%n %Y" \
+ | while read file started; do
+ svc=${file##*/}
+ installed=$(stat -c "%Y" /etc/init.d/$svc)
+ if [ $installed -gt $started ]; then
+ echo $svc
+ fi
+done)
+
+need_reboot=false
+for i; do
+ case $i in
+ /boot)
+ need_reboot=true
+ esac
+done
+
+notify=msg
+if which notify-send > /dev/null; then
+ notify="notify-send"
+fi
+
+if [ -n "$services" ]; then
+ $notify "The following services have been updated and need a restart:" \
+ $services
+fi
+
+case "$(rc --sys)" in
+ LXC|VSERVER) exit 0 ;;
+esac
+
+if $need_reboot ; then
+ $notify "Kernel(s) were updated. You might need to reboot"
+fi
+