aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/vlc-libde265
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/vlc-libde265
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/vlc-libde265')
-rw-r--r--unmaintained/vlc-libde265/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/vlc-libde265/APKBUILD b/unmaintained/vlc-libde265/APKBUILD
new file mode 100644
index 0000000000..80438c729d
--- /dev/null
+++ b/unmaintained/vlc-libde265/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=vlc-libde265
+pkgver=0.1.6
+pkgrel=0
+pkgdesc=" Standalone plugin for VLC 2.x to support decoding of HEVC/H.265 using libde265"
+url="https://github.com/strukturag/vlc-libde265"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="vlc-dev libde265-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/strukturag/vlc-libde265/releases/download/$pkgver/vlc-libde265-$pkgver.tar.gz"
+
+_builddir="$srcdir"/vlc-libde265-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="559567e11a717f8ddbf04dbb9265de8d vlc-libde265-0.1.6.tar.gz"
+sha256sums="33c7e031f2b4dea08e31086803f64d190068a86c6235b17f94f600f161176010 vlc-libde265-0.1.6.tar.gz"
+sha512sums="fdf9d78696879f6194c0767163f7843c57e57cc8d5ecfa2e0753607b5a1c81b428b29f584644196759bf64de6f8d8f3331339420c49e2035aa18b679db541c8d vlc-libde265-0.1.6.tar.gz"