aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/willie
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/willie
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/willie')
-rw-r--r--unmaintained/willie/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/willie/APKBUILD b/unmaintained/willie/APKBUILD
new file mode 100644
index 0000000000..70c52d98fe
--- /dev/null
+++ b/unmaintained/willie/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=willie
+pkgver=4.4.1
+pkgrel=0
+pkgdesc="A lightweight and easy-to-use IRC Utility bot"
+url="http://willie.dftba.net/"
+arch="noarch"
+license="EFL 2.0"
+depends="python py-tz py-lxml py-feedparser py-enchant py-geoip py-praw
+ py-openssl py-mysqldb"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://willie.dftba.net/files/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b40de4b2959abc7d80069b0c0b6e4bb9 willie-4.4.1.tar.gz"
+sha256sums="956c49d1643bfbd15231f2980874e1f25b45540a844d7be4a9a78e206fa34e32 willie-4.4.1.tar.gz"
+sha512sums="902095f52e62021e44376942ee24955e355a5fb51ccf3642cc9176364576aab289f2edc22c2b598793d960715a280c2c8f156f4f3cf9444781b54b864865ba31 willie-4.4.1.tar.gz"