aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/xinput_calibrator
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/xinput_calibrator
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/xinput_calibrator')
-rw-r--r--unmaintained/xinput_calibrator/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/xinput_calibrator/APKBUILD b/unmaintained/xinput_calibrator/APKBUILD
new file mode 100644
index 0000000000..31c3d01c3d
--- /dev/null
+++ b/unmaintained/xinput_calibrator/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xinput_calibrator
+pkgver=0.7.5
+pkgrel=0
+pkgdesc="A generic touchscreen calibration program for X.Org"
+url="http://www.freedesktop.org/wiki/Software/xinput_calibrator"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libxtst-dev libxrandr-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://github.com/downloads/tias/xinput_calibrator/xinput_calibrator-$pkgver.tar.gz"
+
+_builddir="$srcdir"/xinput_calibrator-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --with-gui=x11 \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="20da0a2055a5a75962add8c6b44f60fa xinput_calibrator-0.7.5.tar.gz"