aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/xiphos
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/xiphos
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/xiphos')
-rw-r--r--unmaintained/xiphos/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/xiphos/APKBUILD b/unmaintained/xiphos/APKBUILD
new file mode 100644
index 0000000000..a0dfa9d2cd
--- /dev/null
+++ b/unmaintained/xiphos/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=xiphos
+pkgver=4.0.4
+pkgrel=0
+_pkgex="-20150830"
+pkgdesc="Gnome application for Bible study"
+url="https://sourceforge.net/projects/gnomesword"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="webkitgtk-dev sword-dev gconf-dev libgsf-dev intltool gettext-dev
+ rarian-dev desktop-file-utils gnome-doc-utils util-linux-dev
+ linux-headers biblesync-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://downloads.sourceforge.net/gnomesword/xiphos-$pkgver$_pkgex.tar.gz"
+
+_builddir="$srcdir"/xiphos-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./waf configure --prefix=/usr \
+ --enable-webkit-editor --gtk=3 && \
+ ./waf build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./waf install || return 1
+
+}
+
+md5sums="a1d88b7d6812fd261d71a229999c669d xiphos-4.0.4-20150830.tar.gz"
+sha256sums="413bb8acb444946ccde1fb9fcfa3ff4bdb622cb56995b557f3215fab42193f20 xiphos-4.0.4-20150830.tar.gz"
+sha512sums="337503ee4cc6139ec8724266f3c9c0ce5d17518c48f7aab03ea8213165054854c8dd7317ff9e1b9097ece12292b52f1c8002684c00c5a7b43c5b4810edd6ecda xiphos-4.0.4-20150830.tar.gz"