aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libndp/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/community/libndp/APKBUILD b/community/libndp/APKBUILD
index 52e9d4372e..a8b360fe1c 100644
--- a/community/libndp/APKBUILD
+++ b/community/libndp/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Library for IPv6 Neighbor Discovery Protocol"
url="http://libndp.org"
arch="all"
-license="GPL-2.1"
+license="LGPL-2.1-or-later"
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/libndp/archive/v$pkgver.tar.gz
@@ -24,16 +24,15 @@ prepare() {
build() {
cd "$builddir"
./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-static \
- --libexecdir=/usr/lib \
- || return 1
- make || return 1
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static \
+ --libexecdir=/usr/lib
+ make
}
check() {
@@ -43,7 +42,7 @@ check() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
sha512sums="9ecaf36656cea8b71b2864eda7e5e2d106c4e861fc7506be9ce309aabee2dfcd695c55f65ae1db4afc1d44cf20b30e1ebf84dbb15d6b39bff5d3833fed57ae19 libndp-1.6.tar.gz