aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libneo4j-client/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/libneo4j-client/APKBUILD b/testing/libneo4j-client/APKBUILD
index 6bb1e08283..b0455be6e0 100644
--- a/testing/libneo4j-client/APKBUILD
+++ b/testing/libneo4j-client/APKBUILD
@@ -14,24 +14,23 @@ install=""
subpackages="$pkgname-dev $pkgname-doc::noarch neo4j-client:client neo4j-client-doc::noarch"
source="https://github.com/cleishm/libneo4j-client/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/"$pkgname-$pkgver"
+builddir="$srcdir"/"$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
- --prefix=/usr \
- || return 1
- make || return 1
- make doc || return 1
+ --prefix=/usr
+ make
+ make doc
}
check() {
- cd "$_builddir"
- make LIBS="-lfts" check || return 1
+ cd "$builddir"
+ make LIBS="-lfts" check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/libneo4j-client
mv doc/html/* "$pkgdir"/usr/share/doc/libneo4j-client/
}