aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/captagent/APKBUILD2
-rw-r--r--community/cassandra-cpp-driver/APKBUILD7
-rw-r--r--community/cassandra-cpp-driver/libuv-1.21-compat.patch25
-rw-r--r--community/h2o/APKBUILD2
-rw-r--r--community/libcouchbase/APKBUILD2
-rw-r--r--community/neovim/APKBUILD2
-rw-r--r--community/nodejs-current/APKBUILD2
-rw-r--r--main/cmake/APKBUILD9
-rw-r--r--main/cmake/libuv-1.21-compat.patch26
-rw-r--r--main/libuv/APKBUILD6
-rw-r--r--main/libuv/musl-dont-have-EFTYPE.patch16
-rw-r--r--main/nodejs/APKBUILD2
-rw-r--r--testing/knot-resolver/APKBUILD2
13 files changed, 89 insertions, 14 deletions
diff --git a/community/captagent/APKBUILD b/community/captagent/APKBUILD
index d636a1a676..7cd26fde05 100644
--- a/community/captagent/APKBUILD
+++ b/community/captagent/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
pkgname=captagent
pkgver=6.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="HEP Capture Agent for HOMER"
url="https://github.com/sipcapture/captagent"
arch="all"
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index 07b8d8bc17..cf00d30a25 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -12,7 +12,9 @@ options="!check" # FIXME: cassandra_integration_tests won't link
depends=""
makedepends="cmake make libressl-dev libuv-dev"
subpackages="$pkgname-dev"
-source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz"
+source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz
+ libuv-1.21-compat.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -31,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz"
+sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz
+5932f13a666b95a40d938f2cc6f3b6eb2107d5d569ff67be470913275816109f7a32426cf1e39ef950b9ba1c7f78063c388805b4106368f9f1527ff15c422241 libuv-1.21-compat.patch"
diff --git a/community/cassandra-cpp-driver/libuv-1.21-compat.patch b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
new file mode 100644
index 0000000000..f2070c985e
--- /dev/null
+++ b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
@@ -0,0 +1,25 @@
+From 0edf3d2eff88d7594ed7dc070f889b1bcacb677f Mon Sep 17 00:00:00 2001
+From: "Tobias C. Berner" <tcberner@FreeBSD.org>
+Date: Sun, 24 Jun 2018 08:25:53 +0200
+Subject: [PATCH] CPP-616 - Use uv/version.h as version file for libuv v1.21.0+
+
+libuv v1.21.0+ changed where the version file is located.
+
+Patch-Source: https://github.com/datastax/cpp-driver/commit/0edf3d2eff88d7594ed7dc070f889b1bcacb677f
+---
+ cmake/modules/CppDriver.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/CppDriver.cmake b/cmake/modules/CppDriver.cmake
+index 92c243d5..098374f9 100644
+--- a/cmake/modules/CppDriver.cmake
++++ b/cmake/modules/CppDriver.cmake
+@@ -372,6 +372,8 @@ macro(CassUseLibuv)
+
+ if (EXISTS "${LIBUV_INCLUDE_DIR}/uv-version.h")
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv-version.h")
++ elseif (EXISTS "${LIBUV_INCLUDE_DIR}/uv/version.h")
++ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv/version.h")
+ else()
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv.h")
+ endif()
diff --git a/community/h2o/APKBUILD b/community/h2o/APKBUILD
index 3b30d5e417..11faa6cbf8 100644
--- a/community/h2o/APKBUILD
+++ b/community/h2o/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bennett Goble <nivardus@gmail.com>
pkgname=h2o
pkgver=2.2.5
-pkgrel=0
+pkgrel=1
pkgdesc="An optimized HTTP/1, HTTP/2 server written in C"
url="https://h2o.examp1e.net"
arch="all"
diff --git a/community/libcouchbase/APKBUILD b/community/libcouchbase/APKBUILD
index ba4f4243de..c0e40b1718 100644
--- a/community/libcouchbase/APKBUILD
+++ b/community/libcouchbase/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname=libcouchbase
pkgver=2.8.7
-pkgrel=0
+pkgrel=1
pkgdesc="C client library for Couchbase"
url="https://developer.couchbase.com/community"
arch="all"
diff --git a/community/neovim/APKBUILD b/community/neovim/APKBUILD
index 579eacf22f..9bffe72f44 100644
--- a/community/neovim/APKBUILD
+++ b/community/neovim/APKBUILD
@@ -13,7 +13,7 @@
# NOTE: ignore-st-cursor-shape.patch will be in neovim 0.2.3
pkgname=neovim
pkgver=0.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Vim-fork focused on extensibility and agility"
url="https://neovim.io"
# s390x: needs luajit
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 898d4bb075..9b926ba6d8 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -13,7 +13,7 @@
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
pkgver=9.11.1
-pkgrel=2
+pkgrel=3
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
arch="all"
diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index e6ddea0e9e..cef461dd04 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
pkgver=3.11.4
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform, open-source make system"
url="http://www.cmake.org"
arch="all"
@@ -18,7 +18,9 @@ case $pkgver in
*.*.*) _v=v${pkgver%.*};;
esac
-source="http://www.cmake.org/files/$_v/cmake-${pkgver}.tar.gz"
+source="http://www.cmake.org/files/$_v/cmake-${pkgver}.tar.gz
+ libuv-1.21-compat.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
_parallel_opt() {
@@ -68,4 +70,5 @@ bashcomp() {
"$subpkgdir"/usr/share/bash-completion/
}
-sha512sums="c5d03ad66a004292038e49e391c390ebc328fbb089ea699742a9b75f0ada9398c3dc971b868f75d8438bf437ecbeaa62541beb53cae14a699bf244ad101a2290 cmake-3.11.4.tar.gz"
+sha512sums="c5d03ad66a004292038e49e391c390ebc328fbb089ea699742a9b75f0ada9398c3dc971b868f75d8438bf437ecbeaa62541beb53cae14a699bf244ad101a2290 cmake-3.11.4.tar.gz
+38c2f594dad56cdfb24a9a272f04ccdad0151296c414c306cb552e71ac14b1c2480702620127f5af5b43875af1be25f7679abfabb3c59e8d6af110ccac4aa7d0 libuv-1.21-compat.patch"
diff --git a/main/cmake/libuv-1.21-compat.patch b/main/cmake/libuv-1.21-compat.patch
new file mode 100644
index 0000000000..df203b62fe
--- /dev/null
+++ b/main/cmake/libuv-1.21-compat.patch
@@ -0,0 +1,26 @@
+From 889033b5c6847cf1f7bd789384405d59dc333bf6 Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Sat, 23 Jun 2018 20:30:07 +0200
+Subject: [PATCH] FindLibUV: Also check uv/version.h for version detection
+
+Starting with libuv 1.21.0, libuv's headers were moved into a uv/ directory.
+Make FindLibUV aware of the file's new location for configuration to work.
+
+Patch-Source: https://github.com/Kitware/CMake/commit/889033b5c6847cf1f7bd789384405d59dc333bf6
+---
+ Source/Modules/FindLibUV.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Source/Modules/FindLibUV.cmake b/Source/Modules/FindLibUV.cmake
+index ba13d75f8be..0554d62c23b 100644
+--- a/Source/Modules/FindLibUV.cmake
++++ b/Source/Modules/FindLibUV.cmake
+@@ -63,6 +63,8 @@ mark_as_advanced(LibUV_INCLUDE_DIR)
+ set(_LibUV_H_REGEX "#[ \t]*define[ \t]+UV_VERSION_(MAJOR|MINOR|PATCH)[ \t]+[0-9]+")
+ if(LibUV_INCLUDE_DIR AND EXISTS "${LibUV_INCLUDE_DIR}/uv-version.h")
+ file(STRINGS "${LibUV_INCLUDE_DIR}/uv-version.h" _LibUV_H REGEX "${_LibUV_H_REGEX}")
++elseif(LibUV_INCLUDE_DIR AND EXISTS "${LibUV_INCLUDE_DIR}/uv/version.h")
++ file(STRINGS "${LibUV_INCLUDE_DIR}/uv/version.h" _LibUV_H REGEX "${_LibUV_H_REGEX}")
+ elseif(LibUV_INCLUDE_DIR AND EXISTS "${LibUV_INCLUDE_DIR}/uv.h")
+ file(STRINGS "${LibUV_INCLUDE_DIR}/uv.h" _LibUV_H REGEX "${_LibUV_H_REGEX}")
+ else()
diff --git a/main/libuv/APKBUILD b/main/libuv/APKBUILD
index 04eea87a18..4c6b988420 100644
--- a/main/libuv/APKBUILD
+++ b/main/libuv/APKBUILD
@@ -2,7 +2,7 @@
# Conttributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libuv
-pkgver=1.20.2
+pkgver=1.21.0
pkgrel=0
pkgdesc="Cross-platform asychronous I/O"
url="http://libuv.org"
@@ -11,6 +11,7 @@ license="MIT BSD ISC"
makedepends="automake autoconf libtool linux-headers"
subpackages="$pkgname-dev $pkgname-dbg"
source="https://dist.libuv.org/dist/v$pkgver/$pkgname-v$pkgver.tar.gz
+ musl-dont-have-EFTYPE.patch
disable-setuid-test.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -45,5 +46,6 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="e39ba5d2fab83d735a1b3bb3191e1ce970c78d3d8745b9d0aa0d2c32bd82c84ff0899cb5c06a4a8b2734d010a59653807374e38a364835d12d3c1d208c33b754 libuv-v1.20.2.tar.gz
+sha512sums="643ec3fc7c1f42e33f54a4cca5ed33a4128e12619036d1deb2b9b57bbb38ded2e4298b9a7340916d996e374fa81861cef0eecf8a8837803cfc5073f19903d1c7 libuv-v1.21.0.tar.gz
+06d30dfba78f0cfa46c1c686beaa572681d55fa63f11068aee551639e73e4b06aa66d6b8df561ec4ed3cb3f3bf775a7e01b3f3c2cd046cff34303d6574b736dd musl-dont-have-EFTYPE.patch
081b98efa33264d326d998f32600635efd5723de1d9836b99039c60168580c7f56a7ea9fdd138f41bb1aede11da70079cce4aa69ea5b954b7f9e4dcad53ba16a disable-setuid-test.patch"
diff --git a/main/libuv/musl-dont-have-EFTYPE.patch b/main/libuv/musl-dont-have-EFTYPE.patch
new file mode 100644
index 0000000000..e0f220915b
--- /dev/null
+++ b/main/libuv/musl-dont-have-EFTYPE.patch
@@ -0,0 +1,16 @@
+EFTYPE is a glibc specific error type.
+
+This patch fixed build error in libcouchbase.
+
+See-Also: https://github.com/libuv/libuv/pull/1836
+
+--- a/include/uv.h
++++ b/include/uv.h
+@@ -142,7 +142,6 @@
+ XX(EHOSTDOWN, "host is down") \
+ XX(EREMOTEIO, "remote I/O error") \
+ XX(ENOTTY, "inappropriate ioctl for device") \
+- XX(EFTYPE, "inappropriate file type or format") \
+
+ #define UV_HANDLE_TYPE_MAP(XX) \
+ XX(ASYNC, async) \
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index d0f75be0ae..0ac59bad22 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -26,7 +26,7 @@ pkgname=nodejs
# Note: Update only to even-numbered versions (e.g. 6.y.z, 8.y.z)!
# Odd-numbered versions are supported only for 9 months by upstream.
pkgver=8.11.3
-pkgrel=1
+pkgrel=2
pkgdesc="JavaScript runtime built on V8 engine - LTS version"
url="https://nodejs.org/"
arch="all"
diff --git a/testing/knot-resolver/APKBUILD b/testing/knot-resolver/APKBUILD
index 471f9b0c6a..47d89a0df3 100644
--- a/testing/knot-resolver/APKBUILD
+++ b/testing/knot-resolver/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=knot-resolver
pkgver=2.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="Minimalistic caching DNS resolver implementation"
url="https://www.knot-resolver.cz/"
# luajit is not available for disabled arches